[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#601328: marked as done (wavesurfer: Unable to use with libsnack2-alsa (provides libsnack2) as it depends on versioned libsnack2)



Your message dated Mon, 11 Apr 2011 09:13:03 +0000
with message-id <E1Q9DB9-0001BE-5y@franck.debian.org>
and subject line Bug#622188: Removed package(s) from unstable
has caused the Debian Bug report #601328,
regarding wavesurfer: Unable to use with libsnack2-alsa (provides libsnack2) as it depends on versioned libsnack2
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact owner@bugs.debian.org
immediately.)


-- 
601328: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=601328
Debian Bug Tracking System
Contact owner@bugs.debian.org with problems
--- Begin Message ---
Package: wavesurfer
Version: 1.8.5-2ubuntu2~mh1
Severity: important

Wavesurfer
  Depends: libsnack2 (>= 2.2)
which makes it impossibe to use with libsnack2-alsa, which although it
  Provides: libsnack2
does not work with wavesurfer as the wavesurfer dependency is versioned.

Als libsnack2 is using OSS, this makes it impossible to use wavesurfer on a
system without /dev/dsp (e.g. Ubuntu Maverick 10.10).

This could be solved by using e.g.
  Depends: libsnack2-alsa (>= 2.2) | libsnack2 (>= 2.2)
or
  Depends: libsnack2 (>= 2.2) | libsnack2-alsa (>= 2.2)
or
  Depends: libsnack2
  Conflicts:  libsnack2 (<< 2.2)

I've been using wavesurfer with libsnack2-alsa now for a while, without any
problems for playback. Recording seems to work ok, but as I have no microphone
I can't really check.

Thanks for considering!



-- System Information:
Debian Release: squeeze/sid
  APT prefers maverick-updates
  APT policy: (500, 'maverick-updates'), (500, 'maverick-security'), (500, 'maverick-proposed'), (500, 'maverick-backports'), (500, 'maverick')
Architecture: amd64 (x86_64)

Kernel: Linux 2.6.35-22-generic (SMP w/4 CPU cores)
Locale: LANG=nl_BE.utf8, LC_CTYPE=nl_BE.utf8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash

Versions of packages wavesurfer depends on:
ii  libsnack2-alsa [libsnack2 2.2.10-dfsg1-9 Sound extension to Tcl/Tk and Pyth
ii  tk8.4                     8.4.19-4       Tk toolkit for Tcl and X11, v8.4 -

wavesurfer recommends no packages.

wavesurfer suggests no packages.

-- no debconf information



--- End Message ---
--- Begin Message ---
Version: 1.8.5-3+rm

Dear submitter,

as the package wavesurfer has just been removed from the Debian archive
unstable we hereby close the associated bug reports.  We are sorry
that we couldn't deal with your issue properly.

For details on the removal, please see http://bugs.debian.org/622188

The version of this package that was in Debian prior to this removal
can still be found using http://snapshot.debian.org/.

This message was generated automatically; if you believe that there is
a problem with it please contact the archive administrators by mailing
ftpmaster@debian.org.

Debian distribution maintenance software
pp.
Alexander Reichle-Schmehl (the ftpmaster behind the curtain)


--- End Message ---

Reply to: