[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#354343: marked as done (xnc-setup, and so xnc segfaults because it cannot find hardcoded font)

Your message dated Sun, 05 Sep 2010 15:21:08 +0000
with message-id <E1OsH1o-0001Jg-KY@merkel.debian.org>
and subject line Package xnc has been removed from Debian
has caused the Debian Bug report #354343,
regarding xnc-setup, and so xnc segfaults because it cannot find hardcoded font
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact owner@bugs.debian.org

354343: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=354343
Debian Bug Tracking System
Contact owner@bugs.debian.org with problems
--- Begin Message ---
Package: xnc
Version: 5.0.4-2.1
Severity: normal

When I try to start xnc-setup, to configure my xnc I have this error:
~$ xncsetup
Loading resources....xncsetup: Error loading font -*-helvetica-*-r-*-*-12-*-*-*-*-*-*-*
Segmentation fault

This is fresh install of xnc, on fresh Debian. I have xnc running on different
To run xnc-setup and configure xnc in my own way I need font helvetica. Of
course it will be better if xnc could select one of the currently installed
fonts instead of trying this one. 
As long as this font is hardcoded it is like dependency of this package. Maybe
package with this font should be added to Depends filed of xnc.
I can do strace, and apt-file on different machine to find-out this package if
you wan't :-P.

-- System Information:
Debian Release: testing/unstable
  APT prefers unstable
  APT policy: (500, 'unstable')
Architecture: powerpc (ppc)
Shell:  /bin/sh linked to /bin/bash
Kernel: Linux 2.6.15-1-powerpc
Locale: LANG=pl_PL.UTF-8, LC_CTYPE=pl_PL.UTF-8 (charmap=UTF-8)

Versions of packages xnc depends on:
ii  libc6                     2.3.6-1        GNU C Library: Shared libraries an
ii  libgcc1                   1:4.0.2-9      GCC support library
ii  libice6                   6.9.0.dfsg.1-4 Inter-Client Exchange library
ii  libjpeg62                 6b-11          The Independent JPEG Group's JPEG 
ii  libpng12-0                1.2.8rel-5     PNG library - runtime
ii  libsm6                    6.9.0.dfsg.1-4 X Window System Session Management
ii  libstdc++6                4.0.2-9        The GNU Standard C++ Library v3
ii  libtiff4                  3.8.0-2        Tag Image File Format (TIFF) libra
ii  libx11-6                  6.9.0.dfsg.1-4 X Window System protocol client li
ii  libxext6                  6.9.0.dfsg.1-4 X Window System miscellaneous exte
ii  zlib1g                    1:1.2.3-9      compression library - runtime

xnc recommends no packages.

-- no debconf information

--- End Message ---
--- Begin Message ---
Version: 5.0.4-4+rm

You filed the bug http://bugs.debian.org/354343 in Debian BTS
against the package xnc. I'm closing it at *unstable*, but it will
remain open for older distributions.

For more information about this package's removal, read
http://bugs.debian.org/595604. That bug might give the reasons why
this package was removed and suggestions of possible replacements.

Don't hesitate to reply to this mail if you have any question.

Thank you for your contribution to Debian.

Luca Falavigna

--- End Message ---

Reply to: