[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#92006: marked as done (Problems swapping over NFS.)

Your message dated Wed, 1 Sep 2010 15:36:06 +0200
with message-id <20100901133606.GJ12469@melusine.alphascorpii.net>
and subject line Package got removed
has caused the Debian Bug report #92006,
regarding Problems swapping over NFS.
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact owner@bugs.debian.org

92006: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=92006
Debian Bug Tracking System
Contact owner@bugs.debian.org with problems
--- Begin Message ---
Package: swapd
Version: 0.2-1


I have a problem with swapd. As far as I can see it is more a
problem with the kernel (or some library) because the error
message that I get is not generated by swapd, but are caused by

This is what I get on the console (a _lot_ of times).

rw_swap_file: bad swap file
Unable to find swap-space signature

I have bit special setup. I'm researching how NFS-boot works and
needs some possibility for the machine to have a swap over the
network. And this actually works, but just for some time.

And because of this above error I realized an other problem. When
using the default setup:

maxswaps 0

When this error is triggered, swapd creates a new file, which
triggers this error, and creates a new file, and so on. I noticed
it becuase it had created swap file on the server that was
totaly about 13 Gb. :)

Setting maxswaps to an other value made it not to go crazy but
the above error message is still there. And I assume that
that means that it is not working.

According to mkswap man page there can be some problems with
files with holes and swap over nfs. So do you know how the
files are generated. I tried to read the source but maybe
asking you is better. :)

One more thing. I have commented out the swapdir /swap
and use --swapdir /swap/some_address which works but
may have some implications. I do not know.

Well I report this becuase I want to ask you if you know
anything about this great little application or if my
problem can be solved in some other (more robust) way? And
I also (of course) report this because you should be
aware of it if somebody else asks...

Some data:
Latest upgrade of sid.
kernel 2.4.2 (compiled by me). Not sure how many swapfiles
the kernel supports. Can that be the problem?

Well that's about it right now. :)


// Ola

 --------------------- Ola Lundqvist ---------------------------
/  opal@debian.org                     Björnkärrsgatan 5 A.11   \
|  opal@lysator.liu.se                 584 36 LINKÖPING         |
|  +46 (0)13-17 69 83                  +46 (0)70-332 1551       |
|  http://www.opal.dhs.org             UIN/icq: 4912500         |
\  gpg/f.p.: 7090 A92B 18FE 7994 0C36  4FE4 18A1 B1CF 0FE5 3DD9 /

--- End Message ---
--- Begin Message ---
Version: 0.2-11+rm


As the package got removed from the archive (Please see
http://bugs.debian.org/595091 for details) I hereby close these bug

Best Regards,

--- End Message ---

Reply to: