[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#591158: darcs-buildpackage: FTBFS: Unsatisfiable build-dependency: xpdf-utils: Depends: poppler-utils

Source: darcs-buildpackage
Severity: serious
Tags: squeeze sid
User: debian-qa@lists.debian.org
Usertags: qa-ftbfs-20100731 qa-ftbfs
Justification: FTBFS on amd64


During a rebuild of all packages in sid, your package failed to build on

Relevant part:
> ** Using build dependencies supplied by package:
> Build-Depends: debhelper (>= 4.1.80), gtk-doc-tools, sgml2x, docbook-utils, jade, libghc6-missingh-dev (>= 1.0.0), ghc6 (>= 6.8.2), scons, xpdf-utils, lynx, libghc6-network-dev, libghc6-unix-dev, libghc6-hslogger-dev, libghc6-configfile-dev
> ┌──────────────────────────────────────────────────────────────────────────────┐
> │ Install build dependencies (internal resolver)                               │
> └──────────────────────────────────────────────────────────────────────────────┘
> Checking for already installed source dependencies...
> debhelper: missing
> Using default version 7.9.3
> gtk-doc-tools: missing
> sgml2x: missing
> docbook-utils: missing
> jade: missing
> libghc6-missingh-dev: missing
> Using default version
> ghc6: missing
> Using default version 6.12.1-13
> scons: missing
> xpdf-utils: missing
> lynx: missing
> libghc6-network-dev: missing
> libghc6-unix-dev: missing
> libghc6-hslogger-dev: missing
> libghc6-configfile-dev: missing
> Checking for source dependency conflicts...
> E: Broken packages
> Installing positive dependencies: debhelper gtk-doc-tools sgml2x docbook-utils jade libghc6-missingh-dev ghc6 scons xpdf-utils lynx libghc6-network-dev libghc6-unix-dev libghc6-hslogger-dev libghc6-configfile-dev
> Reading package lists...
> Building dependency tree...
> Reading state information...
> Note, selecting ghc6 instead of libghc6-unix-dev
> Some packages could not be installed. This may mean that you have
> requested an impossible situation or if you are using the unstable
> distribution that some required packages have not yet been created
> or been moved out of Incoming.
> The following information may help to resolve the situation:
> The following packages have unmet dependencies:
>   xpdf-utils: Depends: poppler-utils but it is not going to be installed
> E: Broken packages

Please update your build-dependency to depend on poppler-utils directly.

The full build log is available from:

A list of current common problems and possible solutions is available at 
http://wiki.debian.org/qa.debian.org/FTBFS . You're welcome to contribute!

About the archive rebuild: The rebuild was done on about 50 AMD64 nodes
of the Grid'5000 platform, using a clean chroot.  Internet was not
accessible from the build systems.

| Lucas Nussbaum
| lucas@lucas-nussbaum.net   http://www.lucas-nussbaum.net/ |
| jabber: lucas@nussbaum.fr             GPG: 1024D/023B3F4F |

Reply to: