[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#586605: firmware-b43-installer: do not fail on kernel version mismatch

Package: firmware-b43-installer
Severity: important

firmware-b43-installer currently fails in postinst script on kernel versions <
2.6.25. This makes impossible to install firmware-b43-installer in the
deboostrapped environment, since it may not have a kernel at all, but the host
system has 2.6.18 or similar. postinst script should ask if it's ok to install
firmware-b43-installer anyway (like udev does).

-- System Information:
Debian Release: squeeze/sid
  APT prefers testing
  APT policy: (500, 'testing'), (20, 'unstable')
Architecture: i386 (i686)

Kernel: Linux 2.6.32-4-686-bigmem (SMP w/2 CPU cores)
Locale: LANG=ru_RU.UTF-8, LC_CTYPE=ru_RU.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash

Versions of packages firmware-b43-installer depends on:
ii  b43-fwcutter                  1:013-2    Utility for extracting Broadcom 43
ii  bzip2                         1.0.5-4    high-quality block-sorting file co
ii  wget                          1.12-2     retrieves files from the web

Versions of packages firmware-b43-installer recommends:
ii  linux-image-2.6.32-4-686-bigm 2.6.32-11  Linux 2.6.32 for PCs with 4GB+ RAM

firmware-b43-installer suggests no packages.

-- no debconf information

Reply to: