[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#570527: opencryptoki: broken symlink under /usr/lib/pkcs11

Package: opencryptoki
Version: 2.2.8+dfsg-4
Severity: normal

The symlinks under /usr/lib/pkcs11 point to ../opencryptoki/libopencryptoki.so
but there's no such file. In practice these is
/usr/lib/opencryptoki/libopencryptoki.so.0 that is symlink to

# ls -l  /usr/lib/pkcs11/
kokku 0
lrwxrwxrwx 1 root root 34 19. veebr 16:43 libopencryptoki.so -> ../opencryptoki/libopencryptoki.so
lrwxrwxrwx 1 root root 10 19. veebr 16:43 methods -> ../../sbin
lrwxrwxrwx 1 root root 34 19. veebr 16:43 PKCS11_API.so -> ../opencryptoki/libopencryptoki.so
lrwxrwxrwx 1 root root 21 19. veebr 16:43 stdll -> ../opencryptoki/stdll

Real applications try to use PKCS11_API.so and fail. Fixing the symlinks by hand cures the problem.

The same problem exists in ubuntu 9.10, did not report it there.

-- System Information:
Debian Release: squeeze/sid
  APT prefers unstable
  APT policy: (500, 'unstable')
Architecture: amd64 (x86_64)

Kernel: Linux 2.6.32 (SMP w/2 CPU cores; PREEMPT)
Locale: LANG=et_EE.UTF-8, LC_CTYPE=et_EE.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash

Versions of packages opencryptoki depends on:
ii  adduser                     3.112        add and remove users and groups
hi  libc6                       2.10.2-6     Embedded GNU C Library: Shared lib
ii  libopencryptoki0            2.2.8+dfsg-4 PKCS#11 implementation for Linux (

opencryptoki recommends no packages.

opencryptoki suggests no packages.

-- no debconf information

Reply to: