[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#566296: marked as done (php5-exactimage: ORed phpapi dependency)

Your message dated Sat, 30 Jan 2010 02:02:15 +0000
with message-id <E1Nb2f9-0005ju-Qj@ries.debian.org>
and subject line Bug#566296: fixed in exactimage 0.7.4-3
has caused the Debian Bug report #566296,
regarding php5-exactimage: ORed phpapi dependency
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact owner@bugs.debian.org

566296: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=566296
Debian Bug Tracking System
Contact owner@bugs.debian.org with problems
--- Begin Message ---
Package: php5-exactimage
Version: 0.7.4-2
Severity: important
Usertags: ored-phpapi-dependency


Your package builds a PHP extension and depends on phpapi-* but as an
ORed dependency.
This is incorrect and will break it on PHP transitions, such as the
soon-to-come PHP 5.3 transition.

Please note that in spite of the lintian warning about depending on a
virtual package, you should *NOT* add any of the php SAPIs (-cli,
-cgi, libapache-mod, etc -- and depending on php5-common is incorrect
too) as an ORed dependency to phpapi-. You could add an override if
you insist, but this will likely be handled on lintian's side in a
future version.

Please don't wait, fix it as soon as possible. It will cause problems
when the php 5.3 packages are uploaded to sid.

Thanks in advance.

Raphael Geissert - Debian Developer
www.debian.org - get.debian.net

--- End Message ---
--- Begin Message ---
Source: exactimage
Source-Version: 0.7.4-3

We believe that the bug you reported is fixed in the latest version of
exactimage, which is due to be installed in the Debian FTP archive:

  to main/e/exactimage/exactimage-dbg_0.7.4-3_i386.deb
  to main/e/exactimage/exactimage-perl_0.7.4-3_i386.deb
  to main/e/exactimage/exactimage_0.7.4-3.diff.gz
  to main/e/exactimage/exactimage_0.7.4-3.dsc
  to main/e/exactimage/exactimage_0.7.4-3_i386.deb
  to main/e/exactimage/php5-exactimage_0.7.4-3_i386.deb
  to main/e/exactimage/python-exactimage_0.7.4-3_i386.deb

A summary of the changes between this version and the previous one is

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to 566296@bugs.debian.org,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
Raphael Geissert <geissert@debian.org> (supplier of updated exactimage package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing ftpmaster@debian.org)

Hash: SHA1

Format: 1.8
Date: Fri, 29 Jan 2010 19:26:25 -0600
Source: exactimage
Binary: exactimage exactimage-dbg exactimage-perl php5-exactimage python-exactimage
Architecture: source i386
Version: 0.7.4-3
Distribution: unstable
Urgency: low
Maintainer: Debian QA Group <packages@qa.debian.org>
Changed-By: Raphael Geissert <geissert@debian.org>
 exactimage - fast image manipulation programs
 exactimage-dbg - fast image manipulation programs (utilities)
 exactimage-perl - fast image manipulation programs (Perl bindings)
 php5-exactimage - fast image manipulation programs (PHP bindings)
 python-exactimage - fast image manipulation programs (Python bindings)
Closes: 566296
 exactimage (0.7.4-3) unstable; urgency=low
   * QA upload.
   * Remove alternatives to the phpapi-* dependency (Closes: #566296)
 fc5b83e4030415c3580c0cc3ba2cc98acae01dc0 1330 exactimage_0.7.4-3.dsc
 eb750865b3c7c55461f7075e92bfbcd9e7007df6 12741 exactimage_0.7.4-3.diff.gz
 75bd15bd2fb8b70ef7ab1cebb33073d91aa3a4cd 3433960 exactimage_0.7.4-3_i386.deb
 6d0eda956eb50a61ddc71916fa058855c5e27f05 364514 exactimage-dbg_0.7.4-3_i386.deb
 aae189ed0a3ab465b1aa50b7369d131f8cef2f19 619960 exactimage-perl_0.7.4-3_i386.deb
 e97a25d13d25e5de706772592db2aeb223a5a3a3 594362 php5-exactimage_0.7.4-3_i386.deb
 c50084fc028979c7816bc5131af82e473bc94409 593836 python-exactimage_0.7.4-3_i386.deb
 18e8a587f63a14fced8ef7f74dd869a371bcbbe71e67e4032bff18533ef7cd79 1330 exactimage_0.7.4-3.dsc
 430cf736c747801fa0bf996e428f911a92312bc91bd26e9fa14ec3fd3f734180 12741 exactimage_0.7.4-3.diff.gz
 cda4a18dca561370a0471bf7f3765e6ab099f6b98a603e2ea07c253e2fa6f60d 3433960 exactimage_0.7.4-3_i386.deb
 db9e6352b5c1c785d83724e4395f4e6ca704492569f24dfb5610a4f9194f48d8 364514 exactimage-dbg_0.7.4-3_i386.deb
 221b0c92be5e787d3a68f4ae1a37349c62979d9c6b8b1ce883a7336ba2a631fb 619960 exactimage-perl_0.7.4-3_i386.deb
 96b912df8f5dfb264a4b984d80394d9be0357d0770d327e35549361a9bd645af 594362 php5-exactimage_0.7.4-3_i386.deb
 814dad3dcc8b518cb630063ede4fd40b63631df7fb2345a2d26c98ad7a9f4868 593836 python-exactimage_0.7.4-3_i386.deb
 b39b9bdf65328a1e61354125db8f8588 1330 graphics optional exactimage_0.7.4-3.dsc
 77a06866a3b615d2bc8fd3cb22c1231b 12741 graphics optional exactimage_0.7.4-3.diff.gz
 9f862a4e6e5af0566f36abb6a53a4208 3433960 graphics optional exactimage_0.7.4-3_i386.deb
 a0950d738ea063c8b4bf18027c13fddc 364514 debug extra exactimage-dbg_0.7.4-3_i386.deb
 a18ef97725b94192ba51ee571e06b828 619960 perl optional exactimage-perl_0.7.4-3_i386.deb
 8cc2116e727f446554b68913b45c540d 594362 php optional php5-exactimage_0.7.4-3_i386.deb
 160a8830ea8c8a5c2cc1bb43f835160f 593836 python optional python-exactimage_0.7.4-3_i386.deb

Version: GnuPG v1.4.10 (GNU/Linux)


--- End Message ---

Reply to: