[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#553273: afbackup: read-in-maintainer-script preinst:28

Package: afbackup
Version: 3.5.3-2
Severity: serious
User: lintian-maint@debian.org
Usertags: read-in-maintainer-script

 This maintainer script appears to use read to get information from the
 user. Prompting in maintainer scripts must be done by communicating through a
 program such as debconf which conforms to the Debian Configuration management
 specification, version 2 or higher.
 Refer to Debian Policy Manual section 3.9.1 (Prompting in maintainer scripts)
 for details.
,----[ 3.9.1 Prompting in maintainer scripts ]
| Package maintainer scripts may prompt the user if necessary. Prompting must be
| done by communicating through a program, such as debconf, which conforms to the
| Debian Configuration Management Specification, version 2 or higher.
| Packages which are essential, or which are dependencies of essential packages,
| may fall back on another prompting method if no such interface is available when
| they are executed.
| The Debian Configuration Management Specification is included in the
| debconf_specification files in the debian-policy package. 


-- System Information:
Debian Release: squeeze/sid
  APT prefers unstable
  APT policy: (990, 'unstable'), (500, 'oldstable'), (500, 'stable')
Architecture: amd64 (x86_64)

Kernel: Linux (SMP w/2 CPU cores)
Locale: LANG=en_US.UTF-8, LC_CTYPE=en_US.UTF-8 (charmap=UTF-8) (ignored: LC_ALL set to en_US.UTF-8)
Shell: /bin/sh linked to /bin/dash

Versions of packages afbackup depends on:
pn  afbackup-common             <none>       (no description available)
ii  debianutils                 3.2.1        Miscellaneous utilities specific t
ii  libc6                       2.10.1-3     GNU C Library: Shared libraries
ii  libssl0.9.8                 0.9.8k-5     SSL shared libraries
ii  openbsd-inetd [inet-superse 0.20080125-3 The OpenBSD Internet Superserver
ii  tcsh [c-shell]              6.14.00-7    TENEX C Shell, an enhanced version

afbackup recommends no packages.

Versions of packages afbackup suggests:
pn  afbackup-client               <none>     (no description available)

Reply to: