[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#552092: Cannot purge: invoke-rc.d: initscript trousers, action "stop" failed.

Package: trousers
Version: 0.3.1-10
Severity: serious


trousers does not seem to work for me, so I want to purge it. But
purging trousers does not work:

# dpkg --purge trousers
(Reading database ... 264922 files and directories currently installed.)
Removing trousers ...
Stopping Trusted Computing daemon: invoke-rc.d: initscript trousers, action "stop" failed.
dpkg: error processing trousers (--purge):
 subprocess installed pre-removal script returned error exit status 1
Starting Trusted Computing daemon: tcsd.
Errors were encountered while processing:

A work around is to put an "exit 0" at the beginning of /etc/init.d/trousers



-- System Information:
Debian Release: squeeze/sid
  APT prefers testing
  APT policy: (500, 'testing')
Architecture: amd64 (x86_64)

Kernel: Linux 2.6.30-1-amd64 (SMP w/2 CPU cores)
Locale: LANG=en_GB.UTF-8, LC_CTYPE=en_GB.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/bash

Versions of packages trousers depends on:
ii  adduser                       3.111      add and remove users and groups
ii  libc6                         2.9-25     GNU C Library: Shared libraries
ii  libssl0.9.8                   0.9.8k-5   SSL shared libraries
pn  libtspi1                      <none>     (no description available)

trousers recommends no packages.

trousers suggests no packages.

-- no debconf information

Reply to: