[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#524315: marked as done (otrs2 needs a2enmod during installation)

Your message dated Sun, 11 Oct 2009 22:40:49 +0000
with message-id <E1Mx75t-0002F3-LX@ries.debian.org>
and subject line Bug#524315: fixed in otrs2 2.3.4-3
has caused the Debian Bug report #524315,
regarding otrs2 needs a2enmod during installation
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact owner@bugs.debian.org

524315: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=524315
Debian Bug Tracking System
Contact owner@bugs.debian.org with problems
--- Begin Message ---
Package: otrs2
Version: 2.3.4-1
Severity: important
Tags: patch


on my system the configuration of otrs2 fails with the following error

Creating config file /etc/apache2/conf.d/otrs2 with new version
/var/lib/dpkg/info/otrs2.postinst: line 44: a2enmod: command not found
dpkg: error processing otrs2 (--configure):
 subprocess post-installation script returned error exit status 127
Errors were encountered while processing:
E: Sub-process /usr/bin/dpkg returned an error code (1)

Indeed the binary/command is not there, it is provided by apache2.2-common.
Hence I guess otrs2 needs a dep on apache2.2-common.


-- System Information:
Debian Release: squeeze/sid
  APT prefers unstable
  APT policy: (500, 'unstable')
Architecture: i386 (i686)

Kernel: Linux 2.6.26-2-686 (SMP w/2 CPU cores)
Locale: LANG=en_US.UTF-8, LC_CTYPE=en_US.UTF-8 (charmap=UTF-8) (ignored: LC_ALL set to en_GB.UTF-8)
Shell: /bin/sh linked to /bin/bash

Versions of packages otrs2 depends on:
ii  adduser                    3.110         add and remove users and groups
ii  boa [httpd-cgi]            0.94.14rc21-3 Lightweight and high performance w
ii  dbconfig-common            1.8.41        common framework for packaging dat
ii  debconf                    1.5.26        Debian configuration management sy
ii  libauthen-sasl-perl        2.12-1        Authen::SASL - SASL Authentication
ii  libcrypt-passwdmd5-perl    1.3-9         interoperable MD5-based crypt() fo
ii  libdate-pcalc-perl         1.2-3         Perl module for Gregorian calendar
ii  libdbi-perl                1.607-1       Perl5 database interface by Tim Bu
ii  libemail-valid-perl        0.179-2       Check validity of Internet email a
ii  libio-stringy-perl         2.110-4       Perl modules for IO from scalars a
ii  libmailtools-perl          2.04-1        Manipulate email in perl programs
ii  libmime-tools-perl         5.427-2       Perl5 modules for MIME-compliant m
ii  libtext-diff-perl          0.35-3        Perform diffs on files and record 
ii  libxml-parser-perl         2.36-1.1+b1   Perl module for parsing XML files
ii  perl                       5.10.0-19     Larry Wall's Practical Extraction 
ii  ucf                        3.0018        Update Configuration File: preserv

Versions of packages otrs2 recommends:
ii  aspell                        0.60.6-1   GNU Aspell spell-checker
pn  libapache2-mod-perl2          <none>     (no description available)
pn  libdbd-pg-perl | libdbd-mysql <none>     (no description available)
pn  libgd-graph-perl              <none>     (no description available)
pn  libgd-text-perl               <none>     (no description available)
pn  libtext-csv-perl              <none>     (no description available)
ii  postgresql-8.3                8.3.7-1    object-relational SQL database, ve
ii  procmail                      3.22-16    Versatile e-mail processor

Versions of packages otrs2 suggests:
pn  libnet-ldap-perl              <none>     (no description available)
pn  otrs2-doc-en | otrs2-doc-de   <none>     (no description available)

-- debconf information:
  otrs2/install-error: abort
  otrs2/remove-error: abort
  otrs2/pgsql/authmethod-admin: ident
  otrs2/pgsql/method: unix socket
  otrs2/db/app-user: otrs
  otrs2/resetdbuser: true
  otrs2/pgsql/changeconf: false
  otrs2/pgsql/authmethod-user: ident
  otrs2/internal/skip-preseed: false
  otrs2/upgrade-backup: true
  otrs2/db/dbname: otrs2
  otrs2/pgsql/admin-user: postgres
  otrs2/dbconfig-reinstall: false
* otrs2/dbconfig-install: true
  otrs2/mysql/method: unix socket
  otrs2/upgrade-error: abort
  otrs2/internal/reconfiguring: false
  otrs2/purge: false
* otrs2/database-type: pgsql
  otrs2/dbconfig-upgrade: true
  otrs2/missing-db-package-error: abort
  otrs2/mysql/admin-user: root

--- End Message ---
--- Begin Message ---
Source: otrs2
Source-Version: 2.3.4-3

We believe that the bug you reported is fixed in the latest version of
otrs2, which is due to be installed in the Debian FTP archive:

  to pool/main/o/otrs2/otrs2_2.3.4-3.diff.gz
  to pool/main/o/otrs2/otrs2_2.3.4-3.dsc
  to pool/main/o/otrs2/otrs2_2.3.4-3_all.deb

A summary of the changes between this version and the previous one is

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to 524315@bugs.debian.org,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
Patrick Matthäi <pmatthaei@debian.org> (supplier of updated otrs2 package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing ftpmaster@debian.org)

Hash: SHA1

Format: 1.8
Date: Sun, 11 Oct 2009 21:31:45 +0200
Source: otrs2
Binary: otrs2
Architecture: source all
Version: 2.3.4-3
Distribution: unstable
Urgency: low
Maintainer: Debian QA Group <packages@qa.debian.org>
Changed-By: Patrick Matthäi <pmatthaei@debian.org>
 otrs2      - Open Ticket Request System
Closes: 524315
 otrs2 (2.3.4-3) unstable; urgency=low
   * QA upload.
   * Only execute a2enmod, if it is available on the system. Thanks for the
     patch to Hilmar Preusse <hille42@web.de>.
     Closes: #524315
   * Add missing patch descriptions. This fixes several
     quilt-patch-missing-description warnings.
   * Add ${misc:Depends} as dependency. Fixes lintian warning.
   * Bump Standards-Version to 3.8.3.
     - Add debian/README.source.
   * Remove unused lintian overrides about both extra-license-file.
   * Use a Vcs-Svn URI, which does not need an authentication. Thanks lintian.
 2d1b1f8761759fca8a28738f9e9e302c761a1921 1131 otrs2_2.3.4-3.dsc
 fee25d0957792f25a54a87a1e08176dfb6d9956e 22269 otrs2_2.3.4-3.diff.gz
 1ab7c1b0202246573e5716a3c7e12e1cefef5c4a 2581218 otrs2_2.3.4-3_all.deb
 f5e268c86c8efb809b37f9567392bfe18f1d03f652effbd66b466bb4a97d1a88 1131 otrs2_2.3.4-3.dsc
 c4da83ba0eca68b9fc74b56bc137875bb8343ed3cdae9ef18d5fc83d2d144b2b 22269 otrs2_2.3.4-3.diff.gz
 3249b4839f54a5edf1ebbc57d03b721a86c4ef714fc5a04ccf106769fa926a81 2581218 otrs2_2.3.4-3_all.deb
 681379c128fcf6e2de134523e64416f7 1131 web optional otrs2_2.3.4-3.dsc
 f99a3516385dc9160668b5a7cfb17ff0 22269 web optional otrs2_2.3.4-3.diff.gz
 6fe5a212d3eab8ec3565770f1ab7ea3a 2581218 web optional otrs2_2.3.4-3_all.deb

Version: GnuPG v1.4.10 (GNU/Linux)


--- End Message ---

Reply to: