[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#550636: liblash-dev: Package dependencies do not match pkg-config requirements

Package: liblash-dev
Version: 0.5.4-2
Severity: important

The pkg-config file /usr/lib/pkgconfig/lash-1.0.pc lists 'jack' and
'alsa' as requirements. The corresponding pkg-config files are
provided by the packages libjack-dev and libasound2-dev, but these
packages are not listed as dependencies of liblash-dev. This means
that a user will not be able to build software using liblash (and
pkg-config) unless they have also installed libjack-dev and
libasound2-dev manually. These packages should be listed as
dependencies of liblash-dev so they are installed automatically as

-- System Information:
Debian Release: squeeze/sid
  APT prefers testing
  APT policy: (900, 'testing')
Architecture: amd64 (x86_64)

Kernel: Linux 2.6.31-rt11 (SMP w/2 CPU cores; PREEMPT)
Locale: LANG=en_US.UTF-8, LC_CTYPE=en_US.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/bash

Versions of packages liblash-dev depends on:
ii  liblash2                      0.5.4-2    LASH Audio Session Handler (LASH) 
ii  uuid-dev                      2.16.1-3   universally unique id library - he

liblash-dev recommends no packages.

liblash-dev suggests no packages.

-- no debconf information

Reply to: