[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#547828: marked as done (kphotobymail: manipulates site-packages/ directly, failing with Python 2.6)

Your message dated Wed, 07 Oct 2009 23:32:54 +0000
with message-id <E1Mvg06-0001eA-GY@ries.debian.org>
and subject line Bug#547828: fixed in kphotobymail 0.4.1-5
has caused the Debian Bug report #547828,
regarding kphotobymail: manipulates site-packages/ directly, failing with Python 2.6
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact owner@bugs.debian.org

547828: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=547828
Debian Bug Tracking System
Contact owner@bugs.debian.org with problems
--- Begin Message ---
Package: kphotobymail
Version: 0.4.1-4
Severity: important
User: debian-python@lists.debian.org
Usertags: python2.6 dist-packages


kphotobymail is built using the Python distutils mechanism.

Starting from Python 2.6, the installation paths for distutils have
changed. Instead of /usr/lib/pythonX.Y/site-packages, the default has
now changed to /usr/local.

The packaging helpers (debhelper, dh, cdbs, python-support,
python-central) will pick automatically these changes, or are being
fixed to do so. However, kphotobymail seems to do some manipulations
in the site-packages/ directory in its build process.

To fix this issue, the recommended approach is to pass
"--install-layout=deb" to the "python setup.py" invocation. This is
already the default if you use dh - or migrate to dh, which is also

When you do that, modules are installed in
/usr/lib/python2.6/dist-packages instead of site-packages. You have
then to either use a *-packages wildcard, or to use
/usr/share/python/python.mk which provides useful functions to
manipulate these directories.


 .''`.      Josselin Mouette
 : :' :
 `. `'   â??I recommend you to learn English in hope that you in
   `-     future understand thingsâ??  -- Jörg Schilling

--- End Message ---
--- Begin Message ---
Source: kphotobymail
Source-Version: 0.4.1-5

We believe that the bug you reported is fixed in the latest version of
kphotobymail, which is due to be installed in the Debian FTP archive:

  to pool/main/k/kphotobymail/kphotobymail_0.4.1-5.diff.gz
  to pool/main/k/kphotobymail/kphotobymail_0.4.1-5.dsc
  to pool/main/k/kphotobymail/kphotobymail_0.4.1-5_all.deb

A summary of the changes between this version and the previous one is

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to 547828@bugs.debian.org,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
Luca Falavigna <dktrkranz@debian.org> (supplier of updated kphotobymail package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing ftpmaster@debian.org)

Hash: SHA1

Format: 1.8
Date: Wed, 07 Oct 2009 22:21:52 +0200
Source: kphotobymail
Binary: kphotobymail
Architecture: source all
Version: 0.4.1-5
Distribution: unstable
Urgency: low
Maintainer: Debian QA Group <packages@qa.debian.org>
Changed-By: Luca Falavigna <dktrkranz@debian.org>
 kphotobymail - PyQt application for uploading photos to flickr
Closes: 547828
 kphotobymail (0.4.1-5) unstable; urgency=low
   * QA upload.
   * Move Python files to a private directory (Closes: #547828):
     + debian/patches/02_setup.py.dpatch:
       - Adjust setup.py to fit Debian packaging.
     + debian/rules:
       - Pass --install-scripts and --install-lib to setup.py call.
       - No longer remove /usr/share/kphotobymail.
       - Create a link for /usr/bin/kphotobymail to point to the script
         located in /usr/share/kphotobymail/kphotobymail.
   * debian/control:
     - No need to build-depend on python-dev, replace it with python.
     - Add XS-Python-Version field, set it to >= 2.3.
 a38bf5201cd58a54b0e70b70e3b9c2d133d86121 1132 kphotobymail_0.4.1-5.dsc
 b3da9fa08b2f41fe4dbffc10566fe27dbeaa513b 4647 kphotobymail_0.4.1-5.diff.gz
 b0eb194bf3c77c8578a0d997f2cf7ed5a09f16ee 42552 kphotobymail_0.4.1-5_all.deb
 c0622f76b0701f5d1d40095311db8c2a669cf5054a4b309a75965560cc776405 1132 kphotobymail_0.4.1-5.dsc
 8b017f1e10af2119bd9e1ca8f70737dfbdf401f4c8c5de37d0f36b044dbc7496 4647 kphotobymail_0.4.1-5.diff.gz
 c4f1385935d3a828c11387bbba88c4692e390b6d2808b3c55b33a06893a9e0fa 42552 kphotobymail_0.4.1-5_all.deb
 253586aad6d6f6956314bd6e00213035 1132 graphics optional kphotobymail_0.4.1-5.dsc
 a8fd7aabb3922fbcf7ada17fb353632c 4647 graphics optional kphotobymail_0.4.1-5.diff.gz
 11969c8cce645b58bb08691f332c6035 42552 graphics optional kphotobymail_0.4.1-5_all.deb

Version: GnuPG v1.4.10 (GNU/Linux)


--- End Message ---

Reply to: