[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#495543: marked as done (x11vnc: Can't load vnc.so as X11 module for remote connect to working X session)

Your message dated Mon, 10 Aug 2009 09:58:34 +0200
with message-id <200908100958.34465.fabo@debian.org>
and subject line Can't load vnc.so as X11 module for remote connect to working X session
has caused the Debian Bug report #495543,
regarding x11vnc: Can't load vnc.so as X11 module for remote connect to working X session
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact owner@bugs.debian.org

495543: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=495543
Debian Bug Tracking System
Contact owner@bugs.debian.org with problems
--- Begin Message ---
Package: x11vnc
Version: 0.9.3.dfsg.1-1
Severity: important

I want to install vnc as Xorg module for remote connecting to active display (system-started method).
In Debian Etch, Fedora and many other systems I do it like in this manual:

1. Install vnc4server
2. Add 'Load "vnc"' and some else string in xorg.conf
3. Restart Xorg
4. Connect to current Xorg display.

But in Lenny I haven't found vnc.so in package vnc4server.
I have found it in x11vnc package.
And now I can't load it as Xorg module. I create a symlink
from /usr/lib/xrdp/libvnc.so to /usr/lib/xorg/modules/vnc.so
and add 'Load "vnc"' line to xorg.conf.
And when X server starts, it shows the errors:
# cat /var/log/Xorg.0.log | grep vnc
(II) LoadModule: "libvnc"
(II) Loading /usr/lib/xrdp//libvnc.so
(EE) LoadModule: Module libvnc does not have a libvncModuleData data object.
(II) UnloadModule: "libvnc"
(II) Unloading /usr/lib/xrdp//libvnc.so
(EE) Failed to load module "libvnc" (invalid module, 0)

I can't find any info about this error in Debian bugs or some else in the Internet: 

Maybe in Lenny there are another method to install vnc as Xorg module?

-- System Information:
Debian Release: lenny/sid
  APT prefers testing
  APT policy: (500, 'testing')
Architecture: amd64 (x86_64)

Kernel: Linux 2.6.25-2-amd64 (SMP w/2 CPU cores)
Locale: LANG=en_US.UTF-8, LC_CTYPE=en_US.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/bash

Versions of packages x11vnc depends on:
ii  libavahi-client3       0.6.22-3          Avahi client library
ii  libavahi-common3       0.6.22-3          Avahi common library
ii  libc6                  2.7-13            GNU C Library: Shared libraries
ii  libjpeg62              6b-14             The Independent JPEG Group's JPEG 
ii  libssl0.9.8            0.9.8g-13         SSL shared libraries
ii  libvncserver0          0.9.3.dfsg.1-1    API to write one's own vnc server
ii  libx11-6               2:1.1.4-2         X11 client-side library
ii  libxdamage1            1:1.1.1-4         X11 damaged region extension libra
ii  libxext6               2:1.0.4-1         X11 miscellaneous extension librar
ii  libxfixes3             1:4.0.3-2         X11 miscellaneous 'fixes' extensio
ii  libxinerama1           2:1.0.3-2         X11 Xinerama extension library
ii  libxrandr2             2:1.2.3-1         X11 RandR extension library
ii  libxtst6               2:1.0.3-1         X11 Testing -- Resource extension 
ii  zlib1g                 1: compression library - runtime

x11vnc recommends no packages.

x11vnc suggests no packages.

-- no debconf information

--- End Message ---
--- Begin Message ---
Version: 4.1.1+X4.3.0-22

* Removed libvnc.so that do not work with recent xorg.

--- End Message ---

Reply to: