[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#208906: marked as done (dependency resolution dialog could be more specific)

Your message dated Mon, 8 Jun 2009 19:19:59 +0100
with message-id <200906081819.n58IJxZ0014927@kmos.homeip.net>
and subject line gnome-apt has been removed from Debian, closing #208906
has caused the Debian Bug report #208906,
regarding dependency resolution dialog could be more specific
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact owner@bugs.debian.org

208906: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=208906
Debian Bug Tracking System
Contact owner@bugs.debian.org with problems
--- Begin Message ---
Package: gnome-apt
Version: 0.4.4-2
Severity: normal

Fire up 'gnome-apt'.  Under 'outdated' I see a new version
of 'file' and click on it.  Pop goes the window:

1	Unsatisfied Dependencies (title)
2	Package    | Version needed | Version to be installed (header)
3	libmagic1    = 4.03-3         4.03-2	(text list)
5	             * needed by file
7	Installing the selected package would introduce unsatisfied dependencies.
8	Should I try adding and/or removing packages to resolve the problems?
10			    [Ignore] [No] [Yes]

Consider line #2.  The third header caption says "Version to be
installed".  That caption is directly above "4.03-2".  But the
'outdated' list shows 'libmagic1' v4.03-2 is the "Inst. Vers." and
v4.03-3 is the "Avail. Vers."  So the third caption is incorrect.

Suggest changing caption headers (or whatever those things are called)
to better match the 'gnome-apt' package list, so line #2 would look more
like one of these:

2       Package    | Avaiable Version (needed) | Installed Version 
2       Package    | Avail. Vers. (needed) | Inst. Vers.

Or swap 'em around, so the order is consistant with that of the
package list:

2       Package   | Inst. Vers.  | Avail. Vers. (needed)

Hope this helps...

-- System Information:
Debian Release: testing/unstable
Architecture: i386
Kernel: Linux Arf 2.4.21-1-k6 #2 Mon Jun 16 22:19:43 EST 2003 i586
Locale: LANG=C, LC_CTYPE=C (ignored: LC_ALL set to C)

Versions of packages gnome-apt depends on:
ii  apt [libapt-pkg-libc6 0.5.10             Advanced front-end for dpkg
ii  apt-utils [libapt-ins 0.5.10             APT utility programs
ii  bonobo-activation     1:2.2.4-1          Bonobo Activation Framework
ii  gksu                  0.9.16             Gtk+ Frontend to su
ii  libart-2.0-2          2.3.15-1           Library of functions for 2D graphi
ii  libatk1.0-0           1.2.4-1            The ATK accessibility toolkit
ii  libaudiofile0         0.2.3-4            The Audiofile Library
ii  libbonobo-activation4 1:2.2.4-1          Bonobo Activation Framework -- run
ii  libbonobo2-0          2.2.3-1            Bonobo CORBA interfaces library
ii  libbonoboui2-0        2.2.4-1            The Bonobo UI library
ii  libc6                 2.3.2-5            GNU C Library: Shared libraries an
ii  libesd0               0.2.29-1           Enlightened Sound Daemon - Shared 
ii  libgcc1               1:3.3.2-0pre2      GCC support library
ii  libgconf2-4           2.2.1-3            GNOME configuration database syste
ii  libgcrypt1            1.1.12-3           LGPL Crypto library - runtime libr
ii  libglib2.0-0          2.2.3-1            The GLib library of C routines
ii  libgnome2-0           2.2.3-2            The GNOME 2 library - runtime file
ii  libgnomecanvas2-0     2.2.1-3            A powerful object-oriented display
ii  libgnomeui-0          2.2.2-2            The GNOME 2 libraries (User Interf
ii  libgnomevfs2-0        2.2.5-3            The GNOME virtual file-system libr
ii  libgnomevfs2-common   2.2.5-3            The GNOME virtual file-system libr
ii  libgnutls7            0.8.9-2            GNU TLS library - runtime library
ii  libgtk2.0-0           2.2.2-3            The GTK+ graphical user interface 
ii  libjpeg62             6b-8               The Independent JPEG Group's JPEG 
ii  liblinc1              2:1.0.3-3          library to simplify creating netwo
ii  liborbit2             1:2.6.3-2          Libraries for ORBit2 - a CORBA ORB
ii  libpango1.0-0         1.2.3-1            Layout and rendering of internatio
ii  libpopt0              1.7-2              lib for parsing cmdline parameters
ii  libstdc++5            1:3.3.2-0pre2      The GNU Standard C++ Library v3
ii  libtasn1-0            0.1.2-1            Manage ASN.1 structures (runtime)
ii  libxml2               2.5.10-1           GNOME XML library
ii  libzvt2.0-0           2.0.1cvs20021009-4 The GNOME 2 zvt (zterm) widget - r
ii  xlibs                 4.2.1-11           X Window System client libraries
ii  zlib1g                1:1.1.4-14         compression library - runtime

-- no debconf information

--- End Message ---
--- Begin Message ---
Version: 0.4.9-5+rm

The gnome-apt package has been removed from Debian so we are closing
the bugs that were still opened against it.

For more information about this package's removal, read
http://bugs.debian.org/414526 . That bug might give the reasons why
this package was removed, and suggestions of possible replacements.

Don't hesitate to reply to this mail if you have any question.

Thank you for your contribution to Debian.

Kind regards,
Marco Rodrigues

--- End Message ---

Reply to: