[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#149663: marked as done (mgp2ps does not manage %area correctly)

Your message dated Wed, 14 Jan 2009 15:05:45 +0100
with message-id <496DF139.4080804@free.fr>
and subject line mgp2ps does not manage %area correctly: bug now solved
has caused the Debian Bug report #149663,
regarding mgp2ps does not manage %area correctly
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact owner@bugs.debian.org

149663: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=149663
Debian Bug Tracking System
Contact owner@bugs.debian.org with problems
--- Begin Message ---
Package: mgp
Version: 1.09a-5
Severity: normal

My .mgp document is:

%include "/usr/share/doc/mgp/examples/default.mgp"



%area 60 100 30 46



I generate the .ps output using:
$ mgp2ps bug.mgp >a.ps

I view it using:
$ gv a.ps

When I display the second (and last) page I have the error:
Error: /undefined in nan
Operand stack:
Execution stack:
   %interp_exit   .runexec2   --nostringval--   --nostringval--
   %--nostringval--   2   %stopped_push   --nostringval--
   %--nostringval--   --nostringval--   false   1   %stopped_push   1
   %3   %oparray_pop   1   3   %oparray_pop   .runexec2
   %--nostringval--   --nostringval--   --nostringval--   2
   %%stopped_push   --nostringval--   --nostringval--   --nostringval--
Dictionary stack:
   --dict:1035/1476(ro)(G)--   --dict:0/20(G)--   --dict:110/200(L)--
Current allocation mode is local
GNU Ghostscript 6.53: Unrecoverable error, exit code 1

Thank you,

-- System Information
Debian Release: 3.0
Architecture: i386
Kernel: Linux trinity 2.4.17 #1 ven mai 3 09:55:26 CEST 2002 i686
Locale: LANG=fr_FR, LC_CTYPE=fr_FR

Versions of packages mgp depends on:
ii  defoma                 0.11.0            Debian Font Manager -- automatic f
ii  imlib1                 1.9.14-2          Imlib is an imaging library for X 
ii  libc6                  2.2.5-6           GNU C Library: Shared libraries an
ii  libpng2                1.0.12-3          PNG library - runtime
ii  libttf2                1.4pre.20011029-1 FreeType 1, The FREE TrueType Font
ii  libungif4g             4.1.0b1-2         shared library for GIF images (run
ii  perl                   5.6.1-7           Larry Wall's Practical Extraction 
ii  perl [perl5]           5.6.1-7           Larry Wall's Practical Extraction 
ii  vflib2                 2.25.1-16         Vector Font Library for Japanese C
ii  xlibs                  4.1.0-16          X Window System client libraries

--- End Message ---
--- Begin Message --- As suggested by http://ekaia.org/blog/2009/01/01/new-years-proposal-look-at-your-reported-bugs/ I tried to reproduce the problem I reported.

I used the same mgp sample and generated the associated .ps file.
I can now display the PostScript file using evince and gv.

I now close the bug.


 Dr. Ludovic Rousseau

--- End Message ---

Reply to: