[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#309182: marked as done (dfm: Better file association defaults (nedit, lyx, xv, netscape ...?))

Your message dated Mon, 5 May 2008 14:21:48 +0100
with message-id <200805051321.m45DLmgX017084@kmos.homeip.net>
and subject line dfm has been removed from Debian, closing #309182
has caused the Debian Bug report #309182,
regarding dfm: Better file association defaults (nedit, lyx, xv, netscape ...?)
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact owner@bugs.debian.org

309182: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=309182
Debian Bug Tracking System
Contact owner@bugs.debian.org with problems
--- Begin Message ---
Package: dfm
Version: 0.99.7-7
Severity: normal

When dfm is started it outputs:

    sh: line 0: type: neditc: not found
    sh: line 0: type: nedit: not found
    sh: line 0: type: xvpicmaker: not found
    sh: line 0: type: exm: not found
    sh: line 0: type: xv: not found
    sh: line 0: type: winterm: not found
    sh: line 0: type: netscape: not found
    sh: line 0: type: lyx: not found

There should be better default values compiled in for Debian system.
These values are defined in:



   nedit    -> xedit
   netscape -> firefox
   xv       -> gimp
   winterm  -> xterm
The calls should also be wrapped inside if-statements in
dfm-0.99.7/src/testinstall.c, see the source:

      if (CreateProgramLink("neditc")!=0)

-- System Information:
Debian Release: 3.1
  APT prefers unstable
  APT policy: (500, 'unstable'), (1, 'experimental')
Architecture: i386 (i686)
Shell:  /bin/sh linked to /bin/bash
Kernel: Linux 2.6.11-1-686
Locale: LANG=C, LC_CTYPE=C (charmap=ISO-8859-1) (ignored: LC_ALL set to en_US)

Versions of packages dfm depends on:
ii  gdk-imlib1               1.9.14-16.2     imaging library for use with gtk (
ii  libc6                    2.3.2.ds1-22    GNU C Library: Shared libraries an
ii  libglib1.2               1.2.10-10       The GLib library of C routines
ii  libgtk1.2                1.2.10-17       The GIMP Toolkit set of widgets fo
ii  xlibs                    4.3.0.dfsg.1-13 X Keyboard Extension (XKB) configu
ii  zlib1g                   1:1.2.2-4       compression library - runtime

-- no debconf information

--- End Message ---
--- Begin Message ---
Version: 0.99.9-2+rm

The dfm package has been removed from Debian testing, unstable and
experimental, so I am now closing the bugs that were still opened
against it.

For more information about this package's removal, read
http://bugs.debian.org/349205 . That bug might give the reasons why
this package was removed, and suggestions of possible replacements.

Don't hesitate to reply to this mail if you have any question.

Thank you for your contribution to Debian.

Marco Rodrigues

--- End Message ---

Reply to: