[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#375807: marked as done (imlib-base: imlib-config --libs shouldn't include -ljpeg -ltiff -lungif -lpng -lz -lm -lXext -L/usr/X11R6/lib -lSM -lICE -lXext -lX11)

Your message dated Thu, 06 Dec 2007 22:32:07 +0000
with message-id <E1J0PGJ-0003rC-1t@ries.debian.org>
and subject line Bug#375807: fixed in imlib 1.9.15-5
has caused the attached Bug report to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what I am
talking about this indicates a serious mail system misconfiguration
somewhere.  Please contact me immediately.)

Debian bug tracking system administrator
(administrator, Debian Bugs database)

--- Begin Message ---
Package: imlib-base
Version: 1.9.14-30
Severity: wishlist


There are spurious dependencies in the output of imlib-config --libs:

-L/usr/lib -lImlib -ljpeg -ltiff -lungif -lpng -lz -lm -lXext -L/usr/X11R6/lib -lSM -lICE -lXext -lX11

-ljpeg -ltiff etc... are _not_ needed in --libs (since the imlib
_interface_ doesn't need functions of these library) and just bring
unneeded dependencies. They should be used only for linking libImlib.so
itself, and put in imlib-config --libs --static (for static linking).


-- System Information:
Debian Release: testing/unstable
  APT prefers testing
  APT policy: (900, 'testing'), (500, 'unstable'), (500, 'stable'), (1, 'experimental')
Architecture: i386 (i686)
Shell:  /bin/sh linked to /bin/bash
Kernel: Linux 2.6.17
Locale: LANG=fr_FR@euro, LC_CTYPE=fr_FR@euro (charmap=ISO-8859-15)

Versions of packages imlib-base depends on:
ii  dpkg                          1.13.21    package maintenance system for Deb

Versions of packages imlib-base recommends:
ii  gdk-imlib11                   1.9.14-30  imaging library for use with gtk
ii  imlib11                       1.9.14-30  Imlib is an imaging library for X 

-- no debconf information

Samuel Thibault <samuel.thibault@ens-lyon.org>
void packerFlushTheToiletFirstThingInTheMorning( void* arg )
 -+- chromium's source code -+-

--- End Message ---
--- Begin Message ---
Source: imlib
Source-Version: 1.9.15-5

We believe that the bug you reported is fixed in the latest version of
imlib, which is due to be installed in the Debian FTP archive:

  to pool/main/i/imlib/gdk-imlib11-dev_1.9.15-5_i386.deb
  to pool/main/i/imlib/gdk-imlib11_1.9.15-5_i386.deb
  to pool/main/i/imlib/gdk-imlib1_1.9.15-5_all.deb
  to pool/main/i/imlib/imlib-base_1.9.15-5_all.deb
  to pool/main/i/imlib/imlib11-dev_1.9.15-5_i386.deb
  to pool/main/i/imlib/imlib11_1.9.15-5_i386.deb
  to pool/main/i/imlib/imlib_1.9.15-5.diff.gz
  to pool/main/i/imlib/imlib_1.9.15-5.dsc

A summary of the changes between this version and the previous one is

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to 375807@bugs.debian.org,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
Sune Vuorela <debian@pusling.com> (supplier of updated imlib package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing ftpmaster@debian.org)

Hash: SHA1

Format: 1.7
Date: Thu, 06 Dec 2007 14:00:10 +0000
Source: imlib
Binary: gdk-imlib1 gdk-imlib11-dev gdk-imlib11 imlib11 imlib-base imlib11-dev
Architecture: source i386 all
Version: 1.9.15-5
Distribution: unstable
Urgency: low
Maintainer: Debian QA Group <packages@qa.debian.org>
Changed-By: Sune Vuorela <debian@pusling.com>
 gdk-imlib1 - compatibility package for gdk-imlib11
 gdk-imlib11 - imaging library for use with gtk
 gdk-imlib11-dev - Header files needed for Gdk-Imlib development
 imlib-base - Common files needed by the Imlib/Gdk-Imlib packages
 imlib11    - Imlib is an imaging library for X and X11
 imlib11-dev - Imlib is an imaging library for X and X11
Closes: 294120 375807 441371
 imlib (1.9.15-5) unstable; urgency=low
   * QA upload
   * Remove ancient suggests (Closes: 441371)
   * Purge loads of unneeded stuff in imlib-config output (Closes: 375807)
   * Fix m4 file (Closes: 294120)
 bf84a11e4f230661e2f096cb61415316 815 graphics optional imlib_1.9.15-5.dsc
 295663ea8d41e9167d94423844964b13 336980 graphics optional imlib_1.9.15-5.diff.gz
 f8418469233cab3797dfd98937d5e1fd 23944 graphics optional imlib-base_1.9.15-5_all.deb
 5d6ccb723d3aa272b8d1d905c1532ee6 16456 oldlibs optional gdk-imlib1_1.9.15-5_all.deb
 4ca1ef06f748b321508005c122b0764d 85716 oldlibs optional imlib11_1.9.15-5_i386.deb
 0b7d99c481b87c2b425e9dac2b1fb15c 90484 libdevel optional imlib11-dev_1.9.15-5_i386.deb
 cffca771221d843dd323d376361144fe 93518 oldlibs optional gdk-imlib11_1.9.15-5_i386.deb
 7f8e6cfaf78805e4a65ab5b9fc555a0a 78290 oldlibs optional gdk-imlib11-dev_1.9.15-5_i386.deb

Version: GnuPG v1.4.6 (GNU/Linux)


--- End Message ---

Reply to: