[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#449348: le: please rebuild against libncursesw5

Package: le
Version: 1.13.4-1
Severity: normal
Tags: l10n

The upstream package description and freshmeat.net article mention that
le is able to edit text in multibyte encodings. This is important,
because Debian defaults to UTF-8 based locales now. However, the Debian
"le" package cannot do this, because it is built against libncurses5,
not libncursesw5. If the libncursesw5-dev package is installed, the
package is built correctly with UTF-8 support, so this is just a simple
matter of changing libncurses5-dev to libncursesw5-dev in Build-Depends.

-- System Information:
Debian Release: lenny/sid
 APT prefers testing
 APT policy: (500, 'testing')
Architecture: i386 (i686)

Kernel: Linux 2.6.22-2-686 (SMP w/2 CPU cores)
Locale: LANG=ru_RU.UTF-8, LC_CTYPE=ru_RU.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/bash

Versions of packages le depends on:
ii  libc6                     2.6.1-1+b1     GNU C Library: Shared libraries
ii  libgcc1                   1:4.2.2-3      GCC support library
ii libncurses5 5.6+20071013-1 Shared libraries for terminal hand

le recommends no packages.

-- no debconf information

Alexander E. Patrakov

Reply to: