[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#398181: dvipng: Dependencies

Package: dvipng
Version: 1.8-1
Severity: minor
Tag: sarge


This bug arose while trying to backport the etch version of dvipng to

The above dvipng version can be built on on sarge but it fails to
find freetype font glyphs if the sarge versions of tetex-extra and
libfreetype6 are installed. Even in this case it works if freetype is
disabled (--freetype0 cmd-line option).

I could only get it to with libfreetype6 (>= 2.2.1) when tetex-extra
is installed.

Note that if tetex-extra is not installed then tex defaults to the
bitmap fonts anyway and so the incompatability with libfreetype does
not arise.

At the moment I am undecided which of the three packages is to
"blame" so I'm keeping the bug with "dvipng".



-- System Information:
Debian Release: testing/unstable
  APT prefers testing
  APT policy: (990, 'testing'), (500, 'unstable'), (1, 'experimental')
Architecture: i386 (i686)
Shell:  /bin/sh linked to /bin/bash
Kernel: Linux 2.6.17-2-686
Locale: LANG=en_IN.UTF-8, LC_CTYPE=en_IN.UTF-8 (charmap=UTF-8)

Versions of packages dvipng depends on:
ii  libc6                       2.3.6.ds1-7  GNU C Library: Shared libraries
ii  libfreetype6                2.2.1-5      FreeType 2 font engine, shared lib
ii  libgd2-xpm                  2.0.33-5.1   GD Graphics Library version 2
ii  libkpathsea4                3.0-23       path search library for teTeX (run
ii  libpng12-0                  1.2.8rel-7   PNG library - runtime
ii  libt1-5                     5.1.0-2      Type 1 font rasterizer library - r
ii  tetex-base                  3.0.dfsg.3-1 Basic TeX input files of teTeX
ii  zlib1g                      1:1.2.3-13   compression library - runtime

dvipng recommends no packages.

-- no debconf information

Attachment: signature.asc
Description: Digital signature

Reply to: