[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#366184: libghc6-c2hs-dev: should pre-depend on ghc6

On Fri, Sep 08, 2006 at 05:05:11PM +0200, Arjan Oosting wrote:
> Sorry for the long delay and thanks for the extra information, it has
> been useful. 

Thanks to you for coming back to this--I meant to and just haven't
gotten around to it.

> So because ghc6 is being upgraded /usr/bin/ghc-pkg is not available and
> the prerm script of libghc6-c2hs-dev fails. This can be fixed by
> calling /usr/lib/ghc-6.4.1/bin/ghc-pkg or calling /usr/bin/ghc-pkg6 in
> the prerm script. 
> So the bug has been found. As libghc6-c2hs-dev is not available in
> unstable anymore I am closing this bug.

Sounds good.  I assume that the same issue would arise for any Debian
package containing a GHC package, right?  If so, I guess this should be
advertised as the correct way to register/deregister GHC packages.


Reply to: