[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#366184: marked as done (libghc6-c2hs-dev: should pre-depend on ghc6)

Your message dated Fri, 08 Sep 2006 17:05:11 +0200
with message-id <1157727911.5165.19.camel@nebula.arriesoft.nl>
and subject line Bug#366184: libghc6-c2hs-dev: should pre-depend on ghc6
has caused the attached Bug report to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what I am
talking about this indicates a serious mail system misconfiguration
somewhere.  Please contact me immediately.)

Debian bug tracking system administrator
(administrator, Debian Bugs database)

--- Begin Message ---
Package: libghc6-c2hs-dev
Version: 0.13.6-4
Severity: important

I just did a big upgrade, and libghc6-c2hs-dev failed:

    Preparing to replace libghc6-c2hs-dev 0.13.6-4 (using .../libghc6-c2hs-dev_0.13.6-4.1_i386.deb) ...
    /var/lib/dpkg/info/libghc6-c2hs-dev.prerm: line 22: ghc-pkg: command not found
    dpkg: warning - old pre-removal script returned error exit status 127
    dpkg - trying script from the new package instead ...
    /var/lib/dpkg/tmp.ci/prerm: line 25: ghc-pkg: command not found
    dpkg: error processing /var/cache/apt/archives/libghc6-c2hs-dev_0.13.6-4.1_i386.deb (--unpack):
     subprocess new pre-removal script returned error exit status 127
    /var/lib/dpkg/info/libghc6-c2hs-dev.postinst: line 26: ghc-pkg: command not found
    dpkg: error while cleaning up:
     subprocess post-installation script returned error exit status 127

ghc-pkg is not available until ghc6 is finished configuring.  Thus, I
think that libghc6-c2hs-dev should pre-depend on ghc6.


-- System Information:
Debian Release: testing/unstable
  APT prefers unstable
  APT policy: (800, 'unstable'), (1, 'experimental')
Architecture: i386 (i686)
Shell:  /bin/sh linked to /bin/bash
Kernel: Linux 2.6.15-1-686
Locale: LANG=en_US.UTF-8, LC_CTYPE=en_US.UTF-8 (charmap=UTF-8)

Versions of packages libghc6-c2hs-dev depends on:
ii  ghc6                          6.4.1-2.1  GHC - the Glasgow Haskell Compilat

libghc6-c2hs-dev recommends no packages.

-- no debconf information

--- End Message ---
--- Begin Message ---
Hi Andrew,

Sorry for the long delay and thanks for the extra information, it has
been useful. 

I have looked at the steps which are performed during the upgrade
following Debian Policy 6.6. The following steps happen during the
combined upgrade of ghc6 and libghc6-c2hs-dev:

Unpack ghc6 fase:
      * old-prerm upgrade 6.4.1-2.1
     - removes runhaskell, haskell-compiler and ghc alternative and all
       their slave alternatives including ghc-pkg. This removes 
      * new-preinst upgrade 6.4.1-2
    - does not exist, so noop
      * files are unpacked
      * old-postrm upgrade 6.4.1-2.1
    - does nothing in this case
      * old files are removed
      * ghc6 6.4.1-2.1 has status "unpacked"

Right now /usr/bin/ghc-pkg does not exists

Unpack libghc6-c2hs-dev: 
  * old-prerm upgrade 0.13.6-4.1
    - calls ghc-pkg unregister c2hs which is not available. 

So because ghc6 is being upgraded /usr/bin/ghc-pkg is not available and
the prerm script of libghc6-c2hs-dev fails. This can be fixed by
calling /usr/lib/ghc-6.4.1/bin/ghc-pkg or calling /usr/bin/ghc-pkg6 in
the prerm script. 

So the bug has been found. As libghc6-c2hs-dev is not available in
unstable anymore I am closing this bug.

Thanks for your help.

Greetings Arjan Oosting

Attachment: signature.asc
Description: Dit berichtdeel is digitaal ondertekend

--- End Message ---

Reply to: