[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#248195: marked as done (tla-buildpackage: make problems ("multiple target patterns" error) when packages version has an epoch)

Your message dated Wed, 06 Sep 2006 14:47:23 -0700
with message-id <E1GL5Ex-0006ZT-5q@spohr.debian.org>
and subject line Bug#248195: fixed in tla-buildpackage 0.9.11
has caused the attached Bug report to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what I am
talking about this indicates a serious mail system misconfiguration
somewhere.  Please contact me immediately.)

Debian bug tracking system administrator
(administrator, Debian Bugs database)

--- Begin Message ---
Package: tla-buildpackage
Version: 0.9.7
Severity: normal

Recently tried to use tla-buildpackage to get and modify the "vim"
package. However, I was not able to build the sources: "make" stopped
with "multiple target patterns" error at one point.

I realized that the make utility does not tolerate colons in the
directory path (at least version 3.80-7, used by me, did not).
In this case, vim-1:6.2 got into the working copy path, causing the make
utility to interpret the colon as a syntactical element at one point,
I guess. This is because this package has an "epoch" version and the
epoch versions contain a colon.

For properly handling packages with an epoch version, I would suggest
that if there is a colon in the version string, it gets converted to 
another character (for example, "_"). The conversion should only affect
the generation of the working copy directory names (and thus, the config

To test this particular case, manually replacing the : with _
in the generated config file, checking out the working copy to the new
location (build-config), and modifying the sanity checks from the pkginit
method made it possible to build the package.

-- System Information:
Debian Release: testing/unstable
  APT prefers unstable
  APT policy: (500, 'unstable')
Architecture: i386 (i686)
Kernel: Linux 2.6.5kt7
Locale: LANG=hu, LC_CTYPE=hu (ignored: LC_ALL set to hu_HU.ISO-8859-2)

Versions of packages tla-buildpackage depends on:
ii  devscripts             Scripts to make the life of a Debi
ii  dpkg-dev                      1.10.21    Package building tools for Debian
ii  python-apt                    0.5.10     Python interface to libapt-pkg
ii  python2.3                     2.3.3-7    An interactive high-level object-o
ii  tla                           1.2-3      arch revision control system
ii  tla-load-dirs                 1.0.12     Import upstream archives into tla/

-- no debconf information

--- End Message ---
--- Begin Message ---
Source: tla-buildpackage
Source-Version: 0.9.11

We believe that the bug you reported is fixed in the latest version of
tla-buildpackage, which is due to be installed in the Debian FTP archive:

  to pool/main/t/tla-buildpackage/tla-buildpackage_0.9.11.dsc
  to pool/main/t/tla-buildpackage/tla-buildpackage_0.9.11.tar.gz
  to pool/main/t/tla-buildpackage/tla-buildpackage_0.9.11_all.deb

A summary of the changes between this version and the previous one is

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to 248195@bugs.debian.org,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
Mohammed Adnène Trojette <adn+deb@diwi.org> (supplier of updated tla-buildpackage package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing ftpmaster@debian.org)

Hash: SHA1

Format: 1.7
Date: Wed,  6 Sep 2006 14:38:02 +0200
Source: tla-buildpackage
Binary: tla-buildpackage
Architecture: source all
Version: 0.9.11
Distribution: unstable
Urgency: medium
Maintainer: Debian QA Group <packages@qa.debian.org>
Changed-By: Mohammed Adnène Trojette <adn+deb@diwi.org>
 tla-buildpackage - Suite to help with Debian packages in Arch archives
Closes: 248195 269528 358317 380974 384259
 tla-buildpackage (0.9.11) unstable; urgency=medium
   * QA upload. (Closes: #384259)
   * Build-Depend on quilt for patch management.
   * Adapt to tla-load-dirs (>= 1.0.28) (Closes: #358317):
      + patch from Lionel-Ã?lie Mamane and Gregory Colpart.
   * Update HTML documentation (Closes: #269528):
      + patch from Gregory Colpart.
   * Support "epoch" version (Closes: #248195):
      + patch from Balazs Ree.
   * Update to new Python Policy (Closes: #380974):
      + compile with default python version.
      + build-depend on python-support.
      + adjust Depends and Build-Depends accordingly.
   * Reorder Build-Depends{,-Indep}.
   * Bump Standards-Version to 3.7.2:
      + update FSF address.
   * Make lintian happier:
      + refer to all binary-* targets in debian/rules.
   * Other cosmetics:
      + remove commented lines.
 5f927d29786e7baf091d1b7c712c04e6 683 devel optional tla-buildpackage_0.9.11.dsc
 93296bfebc99fd17ffbcb515e0b7546e 229325 devel optional tla-buildpackage_0.9.11.tar.gz
 5da42c700e119d76c2841e7d85c2433d 215884 devel optional tla-buildpackage_0.9.11_all.deb

Version: GnuPG v1.4.5 (GNU/Linux)


--- End Message ---

Reply to: