[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#382569: marked as done (Installation breaks Apache due to mod-perl2 old API)

Your message dated Sat, 12 Aug 2006 05:02:51 -0700
with message-id <E1GBsCZ-00064m-NN@spohr.debian.org>
and subject line Bug#382569: fixed in request-tracker3.4 3.4.4-3
has caused the attached Bug report to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what I am
talking about this indicates a serious mail system misconfiguration
somewhere.  Please contact me immediately.)

Debian bug tracking system administrator
(administrator, Debian Bugs database)

--- Begin Message ---
Package: rt3.4-apache2
Version: 3.4.4-2
Severity: grave
Tags: etch

Please see #308503.

When I try to start Apache2, after adding:

Include "/etc/request-tracker3.4/apache2-modperl2.conf"

Apache will fail to start, and I get this in my Apache error log:

[Fri Aug 11 15:08:52 2006] [error] Can't locate Apache2.pm in @INC (@INC contain
s: /usr/local/share/request-tracker3.4/lib /usr/share/request-tracker3.4/lib /et
c/perl /usr/local/lib/perl/5.8.8 /usr/local/share/perl/5.8.8 /usr/lib/perl5 /usr
/share/perl5 /usr/lib/perl/5.8 /usr/share/perl/5.8 /usr/local/lib/site_perl . /e
tc/apache2) at (eval 196) line 3.\n

This can be fixed by altering /etc/request-tracker3.4/apache2-modperl2.conf.
The first PerlModule line should be changed to:

PerlModule Apache2::RequestRec Apache2::compat

-- System Information:
Debian Release: testing/unstable
  APT prefers testing
  APT policy: (500, 'testing')
Architecture: amd64 (x86_64)
Shell:  /bin/sh linked to /bin/bash
Kernel: Linux
Locale: LANG=C, LC_CTYPE=en_US (charmap=ISO-8859-1)

Versions of packages rt3.4-apache2 depends on:
ii  apache2                       2.0.55-4.1 next generation, scalable, extenda
ii  apache2-mpm-prefork [apache2] 2.0.55-4.1 traditional model for Apache2
ii  libapache-dbi-perl            0.94-2     Connect apache server to database 
ii  libapache2-mod-perl2          2.0.2-2    Integration of perl with the Apach

rt3.4-apache2 recommends no packages.

-- no debconf information

--- End Message ---
--- Begin Message ---
Source: request-tracker3.4
Source-Version: 3.4.4-3

We believe that the bug you reported is fixed in the latest version of
request-tracker3.4, which is due to be installed in the Debian FTP archive:

  to pool/main/r/request-tracker3.4/request-tracker3.4_3.4.4-3.diff.gz
  to pool/main/r/request-tracker3.4/request-tracker3.4_3.4.4-3.dsc
  to pool/main/r/request-tracker3.4/request-tracker3.4_3.4.4-3_all.deb
  to pool/main/r/request-tracker3.4/rt3.4-apache2_3.4.4-3_all.deb
  to pool/main/r/request-tracker3.4/rt3.4-apache_3.4.4-3_all.deb
  to pool/main/r/request-tracker3.4/rt3.4-clients_3.4.4-3_all.deb

A summary of the changes between this version and the previous one is

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to 382569@bugs.debian.org,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
Michael Ablassmeier <abi@debian.org> (supplier of updated request-tracker3.4 package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing ftpmaster@debian.org)

Hash: SHA1

Format: 1.7
Date: Sat, 12 Aug 2006 13:40:00 +0200
Source: request-tracker3.4
Binary: rt3.4-apache2 request-tracker3.4 rt3.4-apache rt3.4-clients
Architecture: source all
Version: 3.4.4-3
Distribution: unstable
Urgency: low
Maintainer: Debian QA Group <packages@qa.debian.org>
Changed-By: Michael Ablassmeier <abi@debian.org>
 request-tracker3.4 - Extensible trouble-ticket tracking system
 rt3.4-apache - Apache 1 specific files for request-tracker3.4
 rt3.4-apache2 - Apache 2 specific files for request-tracker3.4
 rt3.4-clients - Mail gateway and command-line interface to request-tracker3.4
Closes: 382569
 request-tracker3.4 (3.4.4-3) unstable; urgency=low
   * QA Upload
   * Update apache2-modperl2.conf to new mod-perl2 API
     Closes: #382569
   * Move debhelper and cdbs to Build-Depends
   * Conforms to latest Standards Version 3.7.2
 fad90d7db49e07769c4188ba0290f726 704 misc optional request-tracker3.4_3.4.4-3.dsc
 bd60f0fda494fc967f404f003891046f 21791 misc optional request-tracker3.4_3.4.4-3.diff.gz
 a069ad20ac0363e5d5dba5bae3547560 1180026 misc optional request-tracker3.4_3.4.4-3_all.deb
 0b74ff86b8b4435e9a64cbf4c9494d65 110812 misc optional rt3.4-clients_3.4.4-3_all.deb
 ad8065032d2cb46df700247ed6010bd4 85328 misc optional rt3.4-apache_3.4.4-3_all.deb
 7c5317505c2e584f44deef7bba4cc9be 85264 misc optional rt3.4-apache2_3.4.4-3_all.deb

Version: GnuPG v1.4.5 (GNU/Linux)


--- End Message ---

Reply to: