[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#381543: multi-gnome-terminal: Fails to work with pam_tmpdir enanbled

Package: multi-gnome-terminal
Version: 1.6.2-12
Severity: important

When pam_tmpdir is enabled, mgt fails to start:
Failed to open CORBA cookie file `/tmp/orbit-simi/cookie': No such file or directory
Failed to obtain CORBA authentication cookie, exiting

It seems like it is looking in the wrong place, since the tmp files are now under /tmp/user/.

To reproduce:
1. Install libpam-tmpdir
2. Add "session optional pam_tmpdir.so" to /etc/pam.d/common-session

Don't enable pam_tmpdir


-- System Information:
Debian Release: 3.1
  APT prefers testing
  APT policy: (500, 'testing')
Architecture: i386 (i686)
Kernel: Linux 2.6.16-20060805
Locale: LANG=en_CA, LC_CTYPE=de_DE.utf8 (charmap=UTF-8)

Versions of packages multi-gnome-terminal depends on:
ii  debconf               Debian configuration management sy
ii  gdk-imlib11            1.9.14-30         imaging library for use with gtk
ii  libart2                1.4.2-19          The GNOME canvas widget - runtime 
ii  libaudiofile0          0.2.6-6           Open-source version of SGI's audio
ii  libc6                  2.3.6-15          GNU C Library: Shared libraries
ii  libdb3                 3.2.9-25          Berkeley v3 Database Libraries [ru
ii  libesd0                0.2.36-3          Enlightened Sound Daemon - Shared 
ii  libglade-gnome0        1:0.17-5          Library to load .glade files at ru
ii  libglade0              1:0.17-5          Library to load .glade files at ru
ii  libglib1.2             1.2.10-9          The GLib library of C routines
ii  libgnome32             1.4.2-32          The GNOME libraries
ii  libgnomesupport0       1.4.2-32          The GNOME libraries (Support libra
ii  libgnomeui32           1.4.2-32          The GNOME libraries (User Interfac
ii  libgnorba27            1.4.2-32          GNOME CORBA services
ii  libgtk1.2              1.2.10-18         The GIMP Toolkit set of widgets fo
ii  libice6                1:1.0.0-3         X11 Inter-Client Exchange library
ii  liborbit0              0.5.17-11.1       Libraries for ORBit - a CORBA ORB
ii  libpopt0               1.10-2            lib for parsing cmdline parameters
ii  libsm6                 1:1.0.0-4         X11 Session Management library
ii  libwrap0               7.6.dbs-8         Wietse Venema's TCP wrappers libra
ii  libx11-6               2:1.0.0-7         X11 client-side library
ii  libxext6               1:1.0.0-4         X11 miscellaneous extension librar
ii  libxi6                 1:1.0.0-5         X11 Input extension library
ii  libxml1                1:1.8.17-10       GNOME XML library
ii  zlib1g                 1:1.2.2-4.sarge.2 compression library - runtime

-- no debconf information

Reply to: