[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#380848: marked as done (Python transition (#2): misnamed package with public modules)

Your message dated Wed, 02 Aug 2006 04:54:43 -0700
with message-id <E1G8FJD-0008J6-8C@spohr.debian.org>
and subject line Bug#380848: fixed in jaxml 3.01-2
has caused the attached Bug report to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what I am
talking about this indicates a serious mail system misconfiguration
somewhere.  Please contact me immediately.)

Debian bug tracking system administrator
(administrator, Debian Bugs database)

--- Begin Message ---
Package: jaxml
Version: 3.01-1
Severity: important

  Hi, your package has been detected as generating a (for most of that
mass bug fill: private) python module/extension that may need an upgrade
to the new Python Policy[1].

  A wiki page[2] explains what has to be done to upgrade your packages
to the new Policy. This bug may be a false positive, in that case,
please just close the bug.

  This bug is part of a mass bug filling, and its severity will be
raised to serious when python will default to python2.4 (which should
happend on tomorrow - Wed 2nd of July). Please note that this bug (even
not being RC) falls under the 0-day NMU policy.

  [1] http://lists.debian.org/debian-devel-announce/2006/06/msg00009.html
  [2] http://wiki.debian.org/DebianPython/NewPolicy
      especially "Notes for packages with private modules/extensions"

Special Notes

  * embedded interpreters: You don't *need* to do anything for your
    package, though using XS/XB-Python-Version is much appreciated as it
    helps tracking your package for binNMUs when python2.4 will become

  * if you need help updating your package, you can either:
     - mail debian-python@lists.debian.org ,
     - tag your bug + help ,
     - come on #debian-python/OFTC.

--- End Message ---
--- Begin Message ---
Source: jaxml
Source-Version: 3.01-2

We believe that the bug you reported is fixed in the latest version of
jaxml, which is due to be installed in the Debian FTP archive:

  to pool/main/j/jaxml/jaxml_3.01-2.diff.gz
  to pool/main/j/jaxml/jaxml_3.01-2.dsc
  to pool/main/j/jaxml/python-jaxml_3.01-2_all.deb

A summary of the changes between this version and the previous one is

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to 380848@bugs.debian.org,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
Pierre Habouzit <madcoder@debian.org> (supplier of updated jaxml package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing ftpmaster@debian.org)

Hash: SHA1

Format: 1.7
Date: Tue,  1 Aug 2006 21:59:33 +0200
Source: jaxml
Binary: python-jaxml
Architecture: source all
Version: 3.01-2
Distribution: unstable
Urgency: low
Maintainer: Debian QA Group <packages@qa.debian.org>
Changed-By: Pierre Habouzit <madcoder@debian.org>
 python-jaxml - Python module for generating XML documents
Closes: 380848
 jaxml (3.01-2) unstable; urgency=low
   * QA Upload.
   * Update package to the new python policy (and even the previous one).
     (Closes: #380848)
   * Switch to cdbs, as it eases the maintenance of such tools, and uses the
     builtin setup.py (instead of custom crude hack).
   * Fix FSF address in debian/copyright.
 293bb38e3201271bbd815b3685796ced 629 interpreters optional jaxml_3.01-2.dsc
 9821e37540aaaf1f8f796d267188ac9e 2482 interpreters optional jaxml_3.01-2.diff.gz
 4cf9ddcfc973b3b50396e24c4758889b 25926 interpreters optional python-jaxml_3.01-2_all.deb

Version: GnuPG v1.4.3 (GNU/Linux)


--- End Message ---

Reply to: