[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#269137: marked as done (libguppi16: utf8 strings does not handled correctly)

Your message dated Fri, 26 May 2006 14:02:55 -0700
with message-id <E1FjjSR-0003cr-AT@spohr.debian.org>
and subject line Bug#269137: fixed in guppi 0.40.3-16
has caused the attached Bug report to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what I am
talking about this indicates a serious mail system misconfiguration
somewhere.  Please contact me immediately.)

Debian bug tracking system administrator
(administrator, Debian Bugs database)

--- Begin Message ---
Package: libguppi16
Version: 0.40.3-10
Severity: important
Tags: patch l10n

-- System Information:
Debian Release: 3.1
  APT prefers testing
  APT policy: (500, 'testing')
Architecture: i386 (i686)
Kernel: Linux 2.4.26
Locale: LANG=ru_RU.KOI8-R, LC_CTYPE=ru_RU.KOI8-R

Versions of packages libguppi16 depends on:
ii  gsfonts          8.14+urwcyr1.0.7pre35-1 Fonts for the Ghostscript interpre
ii  libc6            2.3.2.ds1-13            GNU C Library: Shared libraries an
ii  libgnomeprint15  0.37-5                  The GNOME Print architecture - run

-- no debconf information

I have added utf8 sting handling to libguppi.
without it, gnucash reports can't be displayed in russian.
so i decided to fix it despite the fact what Guppi is long
time unsupported. Added a little utf8 char handling code
directly into source, just to not mess with makefile 
changing and dependencies.

patch against guppi_0.40.3-10 attached.

Attachment: guppi-0.40.3-utf8.patch.bz2
Description: BZip2 compressed data

--- End Message ---
--- Begin Message ---
Source: guppi
Source-Version: 0.40.3-16

We believe that the bug you reported is fixed in the latest version of
guppi, which is due to be installed in the Debian FTP archive:

  to pool/main/g/guppi/guppi_0.40.3-16.diff.gz
  to pool/main/g/guppi/guppi_0.40.3-16.dsc
  to pool/main/g/guppi/libguppi-dev_0.40.3-16_i386.deb
  to pool/main/g/guppi/libguppi16_0.40.3-16_i386.deb

A summary of the changes between this version and the previous one is

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to 269137@bugs.debian.org,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
Aurelien Jarno <aurel32@debian.org> (supplier of updated guppi package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing ftpmaster@debian.org)

Hash: SHA1

Format: 1.7
Date: Fri, 26 May 2006 21:02:39 +0200
Source: guppi
Binary: libguppi16 libguppi-dev
Architecture: source i386
Version: 0.40.3-16
Distribution: unstable
Urgency: low
Maintainer: Debian QA Group <packages@qa.debian.org>
Changed-By: Aurelien Jarno <aurel32@debian.org>
 libguppi-dev - GNOME graph and plot component, development files
 libguppi16 - GNOME graph and plot component
Closes: 129385 269137
 guppi (0.40.3-16) unstable; urgency=low
   * QA Upload.
   * Libtool update.
   * Applied patch from Dmitry Petukhov to add utf-8 support.  Closes: #269137,
 658b087b9797586b94c74d71acddf268 1069 math optional guppi_0.40.3-16.dsc
 563715af0772a067cf9afdd5cfcfbfd6 12743 math optional guppi_0.40.3-16.diff.gz
 0ea640bb45f877a7876af17f9de9bcc6 696102 libs optional libguppi16_0.40.3-16_i386.deb
 11d9f06859857e0ec047f284ed898670 618376 libdevel optional libguppi-dev_0.40.3-16_i386.deb

Version: GnuPG v1.4.3 (GNU/Linux)


--- End Message ---

Reply to: