[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#102972: marked as done (dosemu only works on X enviroment)

Your message dated Thu, 9 Feb 2006 23:34:50 +0100
with message-id <20060209223450.GA16790@localhost>
and subject line cannot reproduce - old bug - closing
has caused the attached Bug report to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what I am
talking about this indicates a serious mail system misconfiguration
somewhere.  Please contact me immediately.)

Debian bug tracking system administrator
(administrator, Debian Bugs database)

--- Begin Message ---
Package: dosemu
Version: 1.0.1-8
Severity: important

When executing /usr/bin/dos from a console (outside X) the emu init
normally but it fails at promptgiving this error:
ERROR: cpu exception in dosemu code outside of VM86()!
trapno: 0x0e  errorcode: 0x00000004  cr2: 0x00200140
eip: 0x401a4887  esp: 0xbffff924  eflags: 0x00010216
cs: 0x0023  ds: 0x002b  es: 0x002b  ss: 0x002b
Page fault: read instruction to linear address: 0x00200140
CPU was in user mode
Exception was caused by non-available page

using it on an xterm or the Xdos version works fine.
(this may be a FB issue)

-- System Information
Debian Release: testing/unstable
Architecture: i386
Kernel: Linux iglu 2.4.4 #7 mar may 1 01:43:31 CEST 2001 i586
Locale: LANG=spanish, LC_CTYPE=es_ES

Versions of packages dosemu depends on:
ii  debconf                  0.9.69          Debian configuration management sy
ii  libc6                    2.2.3-4         GNU C Library: Shared libraries an
ii  xbase-clients            4.1.0-0pre1v1.3 miscellaneous X clients           
ii  xlibs                    4.1.0-0pre1v1.3 X Window System client libraries  
ii  xutils                   4.1.0-0pre1v1.3 X Window System utility programs  

--- End Message ---
--- Begin Message ---
I cannot reproduce the bug with dosemu 1.2.2-1, and there has been no
addition on the bug report between 2001 and today (2006).  I'm closing
this bug because it seems it's related to an old version of dosemu (and
maybe also only one setup).  Feel free to reopen and explain why.

--- End Message ---

Reply to: