[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#327980: marked as done (kmatplot: uninstallable; needs rebuild for the Qt/KDE transition)

Your message dated Sat, 21 Jan 2006 20:58:21 +0100
with message-id <87fynh4ale.fsf@diziet.irb.hr>
and subject line Fixed in kmatplot 0.4-7.1
has caused the attached Bug report to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what I am
talking about this indicates a serious mail system misconfiguration
somewhere.  Please contact me immediately.)

Debian bug tracking system administrator
(administrator, Debian Bugs database)

Received: (at submit) by bugs.debian.org; 12 Sep 2005 23:48:21 +0000
>From asp16@alu.ua.es Mon Sep 12 16:48:21 2005
Return-path: <asp16@alu.ua.es>
Received: from 84-120-66-144.onocable.ono.com (chistera.yi.org) [] 
	by spohr.debian.org with esmtp (Exim 3.36 1 (Debian))
	id 1EEy28-0003Sa-00; Mon, 12 Sep 2005 16:48:20 -0700
Received: from userid 1000 by chistera.yi.org with local (Exim 4.52) 
	  id 1EEy1a-0002SW-Et
	  for submit@bugs.debian.org; Tue, 13 Sep 2005 01:47:48 +0200
From: Adeodato =?utf-8?B?U2ltw7M=?= <asp16@alu.ua.es>
To: submit@bugs.debian.org
Subject: kmatplot: uninstallable; needs rebuild for the Qt/KDE transition
Mime-Version: 1.0
Content-Type: text/plain; charset=utf-8
Content-Disposition: inline
Content-Transfer-Encoding: 8bit
Message-Id: <E1EEy1a-0002SW-Et@chistera.yi.org>
Date: Tue, 13 Sep 2005 01:47:46 +0200
Delivered-To: submit@bugs.debian.org
X-Spam-Checker-Version: SpamAssassin 2.60-bugs.debian.org_2005_01_02 
	(1.212-2003-09-23-exp) on spohr.debian.org
X-Spam-Status: No, hits=-6.8 required=4.0 tests=BAYES_00,FROM_ENDS_IN_NUMS,
	HAS_PACKAGE autolearn=no version=2.60-bugs.debian.org_2005_01_02

Package: kmatplot
Version: 0.4-7
Severity: grave
Tags: sid


  This is a grave bug filed against your package because it depends on
  libqt3c102-mt, which no longer exists, thus rendering yor package
  uninstallable in unstable. As part of the C++ ABI transition, this
  library has moved to the libqt3-mt package.

  Simply recompiling and uploading your package should be enough to fix
  this; as per this mail [1], you need not bump your Qt, kdelibs or aRts
  build-dependencies. Beware, though, that that may not be the case for
  all the involved librares. Also, make sure that you build the package
  in an up to date and clean sid environment, so that final dependencies
  are correct. Please do this as soon as possible in order to accelerate
  the Qt/KDE transition to testing.

    [1] http://lists.debian.org/debian-devel-announce/2005/09/msg00000.html

  Perhaps you find that your package fails to compile with gcc4. If
  that's the case, there's probably a bug about it in the BTS, and it
  may include a patch. If not (or if you have doubts about the
  correctness of the patch), you may be able to find a fix in upstream's
  CVS, or in the Ubuntu distribution. If your package fails only in arm,
  m68k, and hppa, see instructions in the above mail.

  Finally, if there's a strong reason for which your package should not
  be NMUed, please note so in this bug report. Prospective NMUers will
  read your reasoning, and will decide if it's strong enough to delay
  their upload.

  Thanks for your cooperation, and happy hacking!

  P.S.: There may be an already reported bug against this package for
  this very same reason. I've checked for that, and will be merging the
  bugs soon. The reason for still filing this bug was to have the
  opportunity of including the small bits of information above. I
  apologize for the inconvenience.

Received: (at 327980-done) by bugs.debian.org; 21 Jan 2006 19:58:28 +0000
>From mvela@irb.hr Sat Jan 21 11:58:28 2006
Return-path: <mvela@irb.hr>
Received: from mail.irb.hr ([] ident=UNKNOWN)
	by spohr.debian.org with esmtp (Exim 4.50)
	id 1F0OsV-0002nQ-Hw; Sat, 21 Jan 2006 11:58:28 -0800
Received: from diziet.irb.hr (diziet.irb.hr [])
	by mail.irb.hr (8.13.4/8.13.4/Debian-3) with ESMTP id k0LJwA1s028068;
	Sat, 21 Jan 2006 20:58:10 +0100
Received: from diziet.irb.hr (localhost [])
	by diziet.irb.hr (8.13.5/8.13.5/Debian-3) with ESMTP id k0LJwLRH019593;
	Sat, 21 Jan 2006 20:58:21 +0100
Received: (from mvela@localhost)
	by diziet.irb.hr (8.13.5/8.13.5/Submit) id k0LJwLq8019591;
	Sat, 21 Jan 2006 20:58:21 +0100
From: Matej Vela <vela@debian.org>
To: 286533-done@bugs.debian.org, 300867-done@bugs.debian.org,
        326338-done@bugs.debian.org, 327980-done@bugs.debian.org
Subject: Fixed in kmatplot 0.4-7.1
Date: Sat, 21 Jan 2006 20:58:21 +0100
Message-ID: <87fynh4ale.fsf@diziet.irb.hr>
User-Agent: Gnus/5.110004 (No Gnus v0.4) Emacs/21.4 (gnu/linux)
MIME-Version: 1.0
Content-Type: text/plain; charset=us-ascii
X-Scanned-By: MIMEDefang 2.51 on
X-Spam-Checker-Version: SpamAssassin 2.60-bugs.debian.org_2005_01_02 
	(1.212-2003-09-23-exp) on spohr.debian.org
X-Spam-Status: No, hits=-3.0 required=4.0 tests=BAYES_00 autolearn=no 
X-CrossAssassin-Score: 4

Source: kmatplot
Source-Version: 0.4-7.1

Now that kmatplot is orphaned, NMU-fixed bugs can be closed.
The original .changes file follows.

Hash: SHA1

Format: 1.7
Date: Sat, 17 Dec 2005 15:43:54 +0100
Source: kmatplot
Binary: kmatplot
Architecture: source i386
Version: 0.4-7.1
Distribution: unstable
Urgency: low
Maintainer: Hugo van der Merwe <hvdm@debian.org>
Changed-By: Aurelien Jarno <aurel32@debian.org>
 kmatplot   - A Gnuplot-like tool for plotting data sets in 2D or 3D
Closes: 286533 300867 326338 327980
 kmatplot (0.4-7.1) unstable; urgency=low
   * 0-day NMU during BSP.
   * Rebuild for the Qt/KDE transition (closes: bug#327980).
   * Rebuilt for libreadline transition (closes: bug#326338).
   * Applied a patch from Andreas Jochen to make the package buildable with
     gcc-4.0 (closes: bug#300867).
   * Build the shared libraries with -fPIC (closes: bug#286533).
   * Added support for GNU/kFreeBSD.
 8b56850043f9183f2ed8fcb859bb834e 650 math optional kmatplot_0.4-7.1.dsc
 f38868ce5e1a6484517dc01822544a9e 48352 math optional kmatplot_0.4-7.1.diff.gz
 04ec30eefa63174c956d6a66175b8962 735440 math optional kmatplot_0.4-7.1_i386.deb

Version: GnuPG v1.4.2 (GNU/Linux)


Reply to: