[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#312004: marked as done (libapache-reload-perl: Can't "use base" on multiple packages using Apache::Reload)

Your message dated Thu, 03 Nov 2005 16:47:12 -0800
with message-id <E1EXpjc-0006QU-00@spohr.debian.org>
and subject line Bug#312004: fixed in libapache-reload-perl 0.07-5
has caused the attached Bug report to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what I am
talking about this indicates a serious mail system misconfiguration
somewhere.  Please contact me immediately.)

Debian bug tracking system administrator
(administrator, Debian Bugs database)

Received: (at submit) by bugs.debian.org; 4 Jun 2005 19:05:53 +0000
>From fbriere@fbriere.net Sat Jun 04 12:05:53 2005
Return-path: <fbriere@fbriere.net>
Received: from smtp.imars.net [] 
	by spohr.debian.org with esmtp (Exim 3.35 1 (Debian))
	id 1Dedxx-00080h-00; Sat, 04 Jun 2005 12:05:53 -0700
Received: from toroia.hyrule.dyndns.org (modemcable017.4-201-24.mc.videotron.ca [])
	by smtp.imars.net (8.12.11/8.12.11) with ESMTP id j54J53hN017028
	for <submit@bugs.debian.org>; Sat, 4 Jun 2005 12:05:03 -0700 (PDT)
	(envelope-from fbriere@fbriere.net)
Received: by toroia.hyrule.dyndns.org (Postfix, from userid 1000)
	id 8641BB78F; Sat,  4 Jun 2005 15:04:59 -0400 (EDT)
Content-Type: text/plain; charset="us-ascii"
MIME-Version: 1.0
Content-Transfer-Encoding: 7bit
From: Frederic Briere <fbriere@fbriere.net>
To: Debian Bug Tracking System <submit@bugs.debian.org>
Subject: libapache-reload-perl: Can't "use base" on multiple packages using
X-Mailer: reportbug 3.12
Date: Sat, 04 Jun 2005 15:04:59 -0400
Message-Id: <20050604190459.8641BB78F@toroia.hyrule.dyndns.org>
Delivered-To: submit@bugs.debian.org
X-Spam-Checker-Version: SpamAssassin 2.60-bugs.debian.org_2005_01_02 
	(1.212-2003-09-23-exp) on spohr.debian.org
X-Spam-Status: No, hits=-8.0 required=4.0 tests=BAYES_00,HAS_PACKAGE 
	autolearn=no version=2.60-bugs.debian.org_2005_01_02

Package: libapache-reload-perl
Version: 0.07-3
Severity: normal

A lot of head-scratching went into this one.  Basically, if you try:

  use base qw(Foo Bar);

Where both Foo and Bar use Apache::Reload, you'll get:

  Can't multiply inherit %FIELDS

The problem is with register_module() trying to see if there's anything
in %Foobar::FIELDS.  This has the side effect of actually creating the
glob entry *Foobar::FIELDS{HASH}, which leads base.pm to believe that
we're actually using pseudo-hashes.  Hilarity ensues.

To prevent this unpleasantness, register_module() should check whether
or not the glob HASH entry exists, and avoid touching it if it doesn't.

-- System Information:
Debian Release: 3.1
  APT prefers unstable
  APT policy: (500, 'unstable')
Architecture: i386 (i686)
Shell:  /bin/sh linked to /bin/bash
Kernel: Linux 2.6.11-2
Locale: LANG=en_CA, LC_CTYPE=en_CA (charmap=ISO-8859-1)

Versions of packages libapache-reload-perl depends on:
ii  libapache-mod-perl   integration of perl with the Apach
ii  perl                          5.8.4-8    Larry Wall's Practical Extraction 

-- no debconf information

Received: (at 312004-close) by bugs.debian.org; 4 Nov 2005 00:51:39 +0000
>From katie@spohr.debian.org Thu Nov 03 16:51:39 2005
Return-path: <katie@spohr.debian.org>
Received: from katie by spohr.debian.org with local (Exim 3.36 1 (Debian))
	id 1EXpjc-0006QU-00; Thu, 03 Nov 2005 16:47:12 -0800
From: Don Armstrong <don@debian.org>
To: 312004-close@bugs.debian.org
X-Katie: $Revision: 1.56 $
Subject: Bug#312004: fixed in libapache-reload-perl 0.07-5
Message-Id: <E1EXpjc-0006QU-00@spohr.debian.org>
Sender: Archive Administrator <katie@spohr.debian.org>
Date: Thu, 03 Nov 2005 16:47:12 -0800
Delivered-To: 312004-close@bugs.debian.org
X-Spam-Checker-Version: SpamAssassin 2.60-bugs.debian.org_2005_01_02 
	(1.212-2003-09-23-exp) on spohr.debian.org
X-Spam-Status: No, hits=-6.0 required=4.0 tests=BAYES_00,HAS_BUG_NUMBER 
	autolearn=no version=2.60-bugs.debian.org_2005_01_02

Source: libapache-reload-perl
Source-Version: 0.07-5

We believe that the bug you reported is fixed in the latest version of
libapache-reload-perl, which is due to be installed in the Debian FTP archive:

  to pool/main/liba/libapache-reload-perl/libapache-reload-perl_0.07-5.diff.gz
  to pool/main/liba/libapache-reload-perl/libapache-reload-perl_0.07-5.dsc
  to pool/main/liba/libapache-reload-perl/libapache-reload-perl_0.07-5_all.deb

A summary of the changes between this version and the previous one is

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to 312004@bugs.debian.org,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
Don Armstrong <don@debian.org> (supplier of updated libapache-reload-perl package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing ftpmaster@debian.org)

Hash: SHA1

Format: 1.7
Date: Thu,  3 Nov 2005 16:14:23 -0800
Source: libapache-reload-perl
Binary: libapache-reload-perl
Architecture: source all
Version: 0.07-5
Distribution: unstable
Urgency: low
Maintainer: Don Armstrong <don@debian.org>
Changed-By: Don Armstrong <don@debian.org>
 libapache-reload-perl - Reload changed modules in a mod_perl environment
Closes: 274122 312004
 libapache-reload-perl (0.07-5) unstable; urgency=low
   * Adopting this package (closes: #274122)
   * Properly handle multiple inheritence in Apache::Reload [thanks to
     Matej Vela for the patch which was modified slightly] (closes: #312004)
   * Upgrade to standards version 3.6.2 which didn't require any changes
 005088df00c017be0b7b9a1a168c2faf 631 perl optional libapache-reload-perl_0.07-5.dsc
 63d61dbc7afec57034e3911fa57f23eb 2413 perl optional libapache-reload-perl_0.07-5.diff.gz
 903c60cb5425e197b6ff6cf89629af46 9034 perl optional libapache-reload-perl_0.07-5_all.deb

Version: GnuPG v1.4.2 (GNU/Linux)


Reply to: