[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#329334: acl-alisp8: bug in alisp8.sh?

Package: acl-alisp8
Version: 6.2.32
Severity: normal

I found the following in that file 

case $1 in
	echo $0 Rebuilding packages...
	while [ -x $acl_dir/$lisp_builder -a ! -z "$1" ] ; do
	    echo ...rebuilding $1
	    /usr/bin/$lisp_target -q -batch -L $acl_dir/siteinit.cl -e "
(let ((*compile-print* nil)
      (*compile-progress* nil)
      (*compile-verbose*  nil)
      (*require-verbose* nil)
      (*load-verbose* nil))

with high likliness you do not want to have 
/usr/bin/$lisp_target but $acl_dir/$lisp_builder why should one check
for an executable file in the while if one does not use it. If one
installed AllegroCL.

If that is still correct how should one know that there should be e.g
a /usr/bin/alisp8 ?


-- System Information:
Debian Release: 3.1
  APT prefers unstable
  APT policy: (500, 'unstable')
Architecture: amd64 (x86_64)
Shell:  /bin/sh linked to /bin/bash
Kernel: Linux 2.6.11
Locale: LANG=C, LC_CTYPE=C (charmap=ANSI_X3.4-1968)

Versions of packages acl-alisp8 depends on:
ii  acl-pro-installer             6.2.32     Installer for Franz' Allegro 6.2 L
ii  common-lisp-controller        4.18       This is a Common Lisp source and c

Versions of packages acl-alisp8 recommends:
ii  acldoc-el                     6.2.32     Display AllegroCL documentation fr

-- no debconf information

Reply to: