[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#317997: marked as done (Missing shlibs:Depends)

Your message dated Thu, 15 Sep 2005 15:26:14 -0700
with message-id <E1EG2BK-0004Nj-00@spohr.debian.org>
and subject line Bug#317997: fixed in twin 0.5.1-1
has caused the attached Bug report to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what I am
talking about this indicates a serious mail system misconfiguration
somewhere.  Please contact me immediately.)

Debian bug tracking system administrator
(administrator, Debian Bugs database)

Received: (at submit) by bugs.debian.org; 12 Jul 2005 19:10:22 +0000
>From djpig@debian.org Tue Jul 12 12:10:21 2005
Return-path: <djpig@debian.org>
Received: from smtp-1.hut.fi [] 
	by spohr.debian.org with esmtp (Exim 3.35 1 (Debian))
	id 1DsQ97-0004qT-00; Tue, 12 Jul 2005 12:10:21 -0700
Received: from localhost (katosiko.hut.fi [])
	by smtp-1.hut.fi (8.12.10/8.12.10) with ESMTP id j6CJ9oik010396;
	Tue, 12 Jul 2005 22:09:50 +0300
Received: from smtp-1.hut.fi ([])
 by localhost (katosiko.hut.fi []) (amavisd-new, port 10024)
 with LMTP id 14091-42; Tue, 12 Jul 2005 22:09:49 +0300 (EEST)
Received: from djpigpb.djpig.de (a130-233-5-205.debconf5.hut.fi [])
	by smtp-1.hut.fi (8.12.10/8.12.10) with ESMTP id j6CJ3bkU009234;
	Tue, 12 Jul 2005 22:03:37 +0300
Received: from djpig by djpigpb.djpig.de with local (Exim 4.52)
	id 1DsQ1i-0000lj-54; Tue, 12 Jul 2005 22:02:42 +0300
Content-Type: text/plain; charset="us-ascii"
MIME-Version: 1.0
Content-Transfer-Encoding: 7bit
From: Frank Lichtenheld <djpig@debian.org>
To: Debian Bug Tracking System <submit@bugs.debian.org>
Subject: Missing shlibs:Depends
X-Mailer: reportbug 3.15
Date: Tue, 12 Jul 2005 22:02:42 +0300
Message-Id: <E1DsQ1i-0000lj-54@djpigpb.djpig.de>
X-TKK-Virus-Scanned: by amavisd-new-2.1.2-hutcc at katosiko.hut.fi
Delivered-To: submit@bugs.debian.org
X-Spam-Checker-Version: SpamAssassin 2.60-bugs.debian.org_2005_01_02 
	(1.212-2003-09-23-exp) on spohr.debian.org
X-Spam-Status: No, hits=-8.0 required=4.0 tests=BAYES_00,HAS_PACKAGE 
	autolearn=no version=2.60-bugs.debian.org_2005_01_02

Package: libtw
Severity: serious

The packages doesn't use shlibs:Depends in its Depends field so it almost
certainly is missing dependencies. If it would actually would build
I perhaps would care which ones.

Due to this missing dependencies nobody noticed that it never made the
g++ ->3.3 transition ...

	Frank Lichtenheld

-- System Information:
Debian Release: testing/unstable
  APT prefers unstable
  APT policy: (500, 'unstable'), (500, 'testing')
Architecture: powerpc (ppc)
Shell:  /bin/sh linked to /bin/bash
Kernel: Linux 2.6.11-powerpc
Locale: LANG=de_DE.UTF-8, LC_CTYPE=de_DE.UTF-8 (charmap=UTF-8)

Received: (at 317997-close) by bugs.debian.org; 15 Sep 2005 22:39:34 +0000
>From joerg@spohr.debian.org Thu Sep 15 15:39:34 2005
Return-path: <joerg@spohr.debian.org>
Received: from joerg by spohr.debian.org with local (Exim 3.36 1 (Debian))
	id 1EG2BK-0004Nj-00; Thu, 15 Sep 2005 15:26:14 -0700
From: Marco Presi (Zufus) <zufus@debian.org>
To: 317997-close@bugs.debian.org
X-Katie: lisa $Revision: 1.30 $
Subject: Bug#317997: fixed in twin 0.5.1-1
Message-Id: <E1EG2BK-0004Nj-00@spohr.debian.org>
Sender: Joerg Jaspert <joerg@spohr.debian.org>
Date: Thu, 15 Sep 2005 15:26:14 -0700
Delivered-To: 317997-close@bugs.debian.org
X-Spam-Checker-Version: SpamAssassin 2.60-bugs.debian.org_2005_01_02 
	(1.212-2003-09-23-exp) on spohr.debian.org
X-Spam-Status: No, hits=-6.0 required=4.0 tests=BAYES_00,HAS_BUG_NUMBER 
	autolearn=no version=2.60-bugs.debian.org_2005_01_02
X-CrossAssassin-Score: 4

Source: twin
Source-Version: 0.5.1-1

We believe that the bug you reported is fixed in the latest version of
twin, which is due to be installed in the Debian FTP archive:

  to pool/main/t/twin/libtw0-dev_4.5.1-1_i386.deb
  to pool/main/t/twin/libtw0_4.5.1-1_i386.deb
  to pool/main/t/twin/twin_0.5.1-1.diff.gz
  to pool/main/t/twin/twin_0.5.1-1.dsc
  to pool/main/t/twin/twin_0.5.1-1_i386.deb
  to pool/main/t/twin/twin_0.5.1.orig.tar.gz

A summary of the changes between this version and the previous one is

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to 317997@bugs.debian.org,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
Marco Presi (Zufus) <zufus@debian.org> (supplier of updated twin package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing ftpmaster@debian.org)

Hash: SHA1

Format: 1.7
Date: Mon, 12 Sep 2005 22:33:31 -0400
Source: twin
Binary: libtw0-dev libtw0 twin
Architecture: source i386
Version: 0.5.1-1
Distribution: unstable
Urgency: low
Maintainer: Marco Bodrato <bodrato@gulp.linux.it>
Changed-By: Marco Presi (Zufus) <zufus@debian.org>
 libtw0     - a Text mode WINdow environment - required library
 libtw0-dev - a Text mode WINdow environment library, development
 twin       - a Text mode WINdow environment
Closes: 184746 238031 297825 317997
 twin (0.5.1-1) unstable; urgency=low
   * New maintainer (Closes: #238031).
   * New upstream release (Closes: #184746).
   * Upstream moved twdm to /usr/sbin/twdm (correct since it depends on
     library in /usr/lib)
   * Matej Vela <vela@debian.org>: integration of various patches:
     - build with gcc-4.0 (Closes: #297825).
     - added shlibs:Depends in debian/control (Closes: 317997).
     - Corrected typos in control and README.Debian files
   * Marco Bodrato:
     - Removed Changelog.txt from docs, it is changelog!
     - Removed assembly code from shared libs (generating non PIC code)
     - Fixed rawkbd
   * libtw renamed to libtw0
   * bumped standard-versions to
 63a8e2bbc1c5e500a59369531911669a 731 utils optional twin_0.5.1-1.dsc
 28dab6c9b3e0d4c4ca508270ba19b28c 1341448 utils optional twin_0.5.1.orig.tar.gz
 8d59c64d10fbbef4898d8781234340af 9648 utils optional twin_0.5.1-1.diff.gz
 b1656cdb5c8e440965e263a8bc557f0c 439838 utils optional twin_0.5.1-1_i386.deb
 93fed562bc71b92cbdd885230c289182 277720 libs optional libtw0_4.5.1-1_i386.deb
 0f2dfdd47f8278da8d85c78d123bec0d 404412 devel optional libtw0-dev_4.5.1-1_i386.deb

Version: GnuPG v1.4.1 (GNU/Linux)


Reply to: