[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#249104: marked as done (FTBFS: Unsatisfiable Build-Depends)



Your message dated Thu, 20 May 2004 17:17:08 -0400
with message-id <E1BQuua-0004fs-00@newraff.debian.org>
and subject line Bug#249104: fixed in rubymagick 0.1.3-12
has caused the attached Bug report to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what I am
talking about this indicates a serious mail system misconfiguration
somewhere.  Please contact me immediately.)

Debian bug tracking system administrator
(administrator, Debian Bugs database)

--------------------------------------
Received: (at submit) by bugs.debian.org; 15 May 2004 02:37:27 +0000
>From kraai@lafn.org Fri May 14 19:37:27 2004
Return-path: <kraai@lafn.org>
Received: from zoot.lafn.org [206.117.18.6] 
	by spohr.debian.org with esmtp (Exim 3.35 1 (Debian))
	id 1BOp3H-0001WN-00; Fri, 14 May 2004 19:37:27 -0700
Received: from localhost (host-66-81-31-51.rev.o1.com [66.81.31.51])
	by zoot.lafn.org (8.12.3p3/8.12.3) with ESMTP id i4F2bMMa020809
	(version=TLSv1/SSLv3 cipher=RC4-SHA bits=128 verify=NO)
	for <submit@bugs.debian.org>; Fri, 14 May 2004 19:37:24 -0700 (PDT)
	(envelope-from kraai@lafn.org)
Received: from kraai by localhost with local (Exim 4.32)
	id 1BOgQf-0000AA-Gf
	for submit@bugs.debian.org; Fri, 14 May 2004 10:25:01 -0700
Date: Fri, 14 May 2004 10:25:01 -0700
From: Matt Kraai <kraai@ftbfs.org>
To: submit@bugs.debian.org
Subject: FTBFS: Unsatisfiable Build-Depends
Message-ID: <20040514172501.GA616@catalunya>
Mime-Version: 1.0
Content-Type: multipart/mixed; boundary="FCuugMFkClbJLl1L"
Content-Disposition: inline
User-Agent: Mutt/1.5.6i
Sender: Matt Kraai <kraai@lafn.org>
X-Virus-Scanned: clamd / ClamAV version 0.70, clamav-milter version 0.70j
Delivered-To: submit@bugs.debian.org
X-Spam-Checker-Version: SpamAssassin 2.60-bugs.debian.org_2004_03_25 
	(1.212-2003-09-23-exp) on spohr.debian.org
X-Spam-Status: No, hits=-7.3 required=4.0 tests=BAYES_00,DATE_IN_PAST_06_12,
	HAS_PACKAGE autolearn=no version=2.60-bugs.debian.org_2004_03_25
X-Spam-Level: 
X-CrossAssassin-Score: 1


--FCuugMFkClbJLl1L
Content-Type: text/plain; charset=us-ascii
Content-Disposition: inline

Package: rubymagick
Version: 0.1.3-11
Severity: serious
Tags: patch

This package fails to build from source:

 ...
  -> Considering  libmagick-dev (>= 5:5.5.7.9-1.1) | libmagick-dev (<< 4:5.5.7.15)
       Tried versions: 
    -> Does not satisfy version, not trying
       Tried versions: 
    -> Does not satisfy version, not trying
 E: Could not satisfy build-dependency.
 E: pbuilder-satisfydepends failed.
 ...

libmagick-dev no longer exists.  Allowing libmagic6-dev as an
alternative fixes the build.

-- 
Matt Kraai            kraai@ftbfs.org            http://ftbfs.org/

--FCuugMFkClbJLl1L
Content-Type: text/plain; charset=us-ascii
Content-Disposition: attachment; filename=patch

diff -Nru rubymagick-0.1.3-old/debian/control rubymagick-0.1.3/debian/control
--- rubymagick-0.1.3-old/debian/control	2004-05-14 08:59:03.000000000 -0700
+++ rubymagick-0.1.3/debian/control	2004-05-14 09:03:36.000000000 -0700
@@ -2,7 +2,7 @@
 Section: interpreters
 Priority: optional
 Maintainer: Debian QA Group <packages@qa.debian.org>
-Build-Depends: debhelper (>> 3.0.0), libmagick-dev (>= 5:5.5.7.9-1.1) | libmagick-dev (<< 4:5.5.7.15), ruby1.6, ruby1.6-dev
+Build-Depends: debhelper (>> 3.0.0), libmagick6-dev | libmagick-dev (>= 5:5.5.7.9-1.1) | libmagick-dev (<< 4:5.5.7.15), ruby1.6, ruby1.6-dev
 Standards-Version: 3.5.8
 
 Package: rubymagick

--FCuugMFkClbJLl1L--

---------------------------------------
Received: (at 249104-close) by bugs.debian.org; 20 May 2004 21:23:12 +0000
>From katie@ftp-master.debian.org Thu May 20 14:23:12 2004
Return-path: <katie@ftp-master.debian.org>
Received: from newraff.debian.org [208.185.25.31] (mail)
	by spohr.debian.org with esmtp (Exim 3.35 1 (Debian))
	id 1BQv0S-0000IV-00; Thu, 20 May 2004 14:23:12 -0700
Received: from katie by newraff.debian.org with local (Exim 3.35 1 (Debian))
	id 1BQuua-0004fs-00; Thu, 20 May 2004 17:17:08 -0400
From: Frank Lichtenheld <djpig@debian.org>
To: 249104-close@bugs.debian.org
X-Katie: $Revision: 1.49 $
Subject: Bug#249104: fixed in rubymagick 0.1.3-12
Message-Id: <E1BQuua-0004fs-00@newraff.debian.org>
Sender: Archive Administrator <katie@ftp-master.debian.org>
Date: Thu, 20 May 2004 17:17:08 -0400
Delivered-To: 249104-close@bugs.debian.org
X-Spam-Checker-Version: SpamAssassin 2.60-bugs.debian.org_2004_03_25 
	(1.212-2003-09-23-exp) on spohr.debian.org
X-Spam-Status: No, hits=-6.0 required=4.0 tests=BAYES_00,HAS_BUG_NUMBER 
	autolearn=no version=2.60-bugs.debian.org_2004_03_25
X-Spam-Level: 

Source: rubymagick
Source-Version: 0.1.3-12

We believe that the bug you reported is fixed in the latest version of
rubymagick, which is due to be installed in the Debian FTP archive:

rubymagick_0.1.3-12.diff.gz
  to pool/main/r/rubymagick/rubymagick_0.1.3-12.diff.gz
rubymagick_0.1.3-12.dsc
  to pool/main/r/rubymagick/rubymagick_0.1.3-12.dsc
rubymagick_0.1.3-12_i386.deb
  to pool/main/r/rubymagick/rubymagick_0.1.3-12_i386.deb



A summary of the changes between this version and the previous one is
attached.

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to 249104@bugs.debian.org,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
pp.
Frank Lichtenheld <djpig@debian.org> (supplier of updated rubymagick package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing ftpmaster@debian.org)


-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Format: 1.7
Date: Thu, 20 May 2004 22:50:45 +0200
Source: rubymagick
Binary: rubymagick
Architecture: source i386
Version: 0.1.3-12
Distribution: unstable
Urgency: low
Maintainer: Debian QA Group <packages@qa.debian.org>
Changed-By: Frank Lichtenheld <djpig@debian.org>
Description: 
 rubymagick - Ruby interface for ImageMagick
Closes: 249104
Changes: 
 rubymagick (0.1.3-12) unstable; urgency=low
 .
   * QA upload.
   * debian/control: Change Build-Depends to libmagick6-dev (Closes: #249104)
Files: 
 eb83e24fcfddd1c6685b2680496629de 621 interpreters optional rubymagick_0.1.3-12.dsc
 00b79713fb02760a6f0b59394b31248b 18351 interpreters optional rubymagick_0.1.3-12.diff.gz
 ffbc1f6253d7e9af2435eff8944e8f10 140316 interpreters optional rubymagick_0.1.3-12_i386.deb

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.2.4 (GNU/Linux)

iD8DBQFArR1aQbn06FtxPfARAvDRAJ9ZwbFMppzaxTdoY8GQ5LRfrxD54ACfbZFb
WfkjnUng9j+waMynr4We0oc=
=lJdC
-----END PGP SIGNATURE-----



Reply to: