[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#182281: marked as done (Xrm.cc has buggy pointer arithmetic)

Your message dated Mon, 10 May 2004 13:02:14 -0600
with message-id <20040510190214.GE15627@gwolf.org>
and subject line Bug seems fixed (could not reproduce it, source includes patches)
has caused the attached Bug report to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what I am
talking about this indicates a serious mail system misconfiguration
somewhere.  Please contact me immediately.)

Debian bug tracking system administrator
(administrator, Debian Bugs database)

Received: (at submit) by bugs.debian.org; 24 Feb 2003 08:58:13 +0000
>From david@josefine.at Mon Feb 24 02:58:13 2003
Return-path: <david@josefine.at>
Received: from u-120-002.adsl.univie.ac.at (zion) [] 
	by master.debian.org with esmtp (Exim 3.12 1 (Debian))
	id 18nERA-0001AV-00; Mon, 24 Feb 2003 02:58:12 -0600
Received: from david by zion with local (Exim 3.35 #1 (Debian))
	id 18nER7-0001VR-00; Mon, 24 Feb 2003 09:58:09 +0100
Content-Type: text/plain; charset="us-ascii"
MIME-Version: 1.0
Content-Transfer-Encoding: 7bit
From: David Schmitt <david@schmitt.edv-bus.at>
To: Debian Bug Tracking System <submit@bugs.debian.org>
Subject: xosview: can't find "samplesPerSec" resource
X-Mailer: reportbug 2.10
Date: Mon, 24 Feb 2003 09:58:09 +0100
Message-Id: <E18nER7-0001VR-00@zion>
Sender: David Schmitt <david@josefine.at>
Delivered-To: submit@bugs.debian.org
X-Spam-Status: No, hits=-0.2 required=4.0

Package: xosview
Version: 1.8.0-5
Severity: normal

Dear maintainer!

After coming back from holidays I updated xosview and am now surprised
to see this behaviour:

david@zion:~$ xosview -name TEST
Error:  Couldn't find 'samplesPerSec' resource in the resource database!

This doesn't happen without the -name parameter or if the name is
"xosview". The manpage says, that xosview will fallback to "name ==
xosview" but this doesn't seem to happen anymore.

Thanks for your time and work, David

-- System Information:
Debian Release: testing/unstable
Architecture: i386
Kernel: Linux zion 2.4.20-k7-zion-1 #1 Sat Jan 18 18:59:09 CET 2003 i686
Locale: LANG=C, LC_CTYPE=de_AT

Versions of packages xosview depends on:
ii  libc6                      2.3.1-10      GNU C Library: Shared libraries an
ii  libgcc1                    1:3.2.3-0pre1 GCC support library
ii  libstdc++5                 1:3.2.3-0pre1 The GNU Standard C++ Library v3
ii  xlibs                      4.2.1-5       X Window System client libraries

-- no debconf information

Received: (at 182281-done) by bugs.debian.org; 10 May 2004 18:04:05 +0000
>From gwolf@prodigy.net.mx Mon May 10 11:04:05 2004
Return-path: <gwolf@prodigy.net.mx>
Received: from nlpproxy09.prodigy.net.mx (smtp.prodigy.net.mx) [] 
	by spohr.debian.org with esmtp (Exim 3.35 1 (Debian))
	id 1BNF8H-0005j4-00; Mon, 10 May 2004 11:04:05 -0700
Received: from gwolf.org (dsl-200-78-32-127.prodigy.net.mx [])
 by smtp.prodigy.net.mx
 (iPlanet Messaging Server 5.2 HotFix 1.21 (built Sep  8 2003))
 with ESMTP id <0HXI00J09FH39Z@smtp.prodigy.net.mx>; Mon,
 10 May 2004 13:03:03 -0500 (CDT)
Received: by gwolf.org (Postfix, from userid 1000)	id E23584AFE8; Mon,
 10 May 2004 13:02:14 -0600 (CST)
Date: Mon, 10 May 2004 13:02:14 -0600
From: Gunnar Wolf <gwolf@debian.org>
Subject: Bug seems fixed (could not reproduce it, source includes patches)
To: 182281-done@bugs.debian.org
Message-id: <20040510190214.GE15627@gwolf.org>
MIME-version: 1.0
Content-type: text/plain; charset=us-ascii
Content-disposition: inline
User-Agent: Mutt/1.3.28i
Delivered-To: 182281-done@bugs.debian.org
X-Spam-Checker-Version: SpamAssassin 2.60-bugs.debian.org_2004_03_25 
	(1.212-2003-09-23-exp) on spohr.debian.org
X-Spam-Status: No, hits=-1.5 required=4.0 tests=BAYES_01 autolearn=no 
X-CrossAssassin-Score: 1


I am in the process of adopting xosview. I tried to invoke it as
reported by David Schmitt, and it worked correctly. I found in
aclocal.m4 that something very similar to the patch suggested by
Alexander Becher has been applied (although reducing from -O4 to -O2
and removing -pipe). The patch suggested by Derrick 'dman' Hudson was
also applied over one year ago. 

I am closing this bug. Please reopen it if you are still able to
reproduce it.

Gunnar Wolf - gwolf@gwolf.cx - (+52-55)5630-9700 ext. 1366
PGP key 1024D/8BB527AF 2001-10-23
Fingerprint: 0C79 D2D1 2C4E 9CE4 5973  F800 D80E F35A 8BB5 27AF

Reply to: