[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#193023: marked as done (libparagui1.0_1.0.2-1(mips/unstable): configure built with broken libtool.m4)

Your message dated Mon, 12 May 2003 19:17:46 -0400
with message-id <E19FMYE-0006KS-00@auric.debian.org>
and subject line Bug#193023: fixed in libparagui1.0 1.0.2-2
has caused the attached Bug report to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what I am
talking about this indicates a serious mail system misconfiguration
somewhere.  Please contact me immediately.)

Debian bug tracking system administrator
(administrator, Debian Bugs database)

Received: (at submit) by bugs.debian.org; 12 May 2003 11:50:04 +0000
>From rmurray@cyberhqz.com Mon May 12 06:49:56 2003
Return-path: <rmurray@cyberhqz.com>
Received: from h24-77-96-253.sbm.shawcable.net (straylight.cyberhqz.com) [] (postfix)
	by master.debian.org with esmtp (Exim 3.12 1 (Debian))
	id 19FBoS-0005fo-00; Mon, 12 May 2003 06:49:48 -0500
Received: by straylight.cyberhqz.com (Postfix, from userid 1000)
	id 1DF8154035; Mon, 12 May 2003 04:49:47 -0700 (PDT)
Date: Mon, 12 May 2003 04:49:47 -0700
From: Ryan Murray <rmurray@debian.org>
To: submit@bugs.debian.org
Subject: libparagui1.0_1.0.2-1(mips/unstable): configure built with broken libtool.m4
Message-ID: <20030512114946.GD20972@cyberhqz.com>
Mime-Version: 1.0
Content-Type: text/plain; charset=us-ascii
Content-Disposition: inline
User-Agent: Mutt/1.3.28i
Delivered-To: submit@bugs.debian.org
X-Spam-Status: No, hits=-12.3 required=4.0
	autolearn=ham version=2.53-bugs.debian.org_2003_05_09
X-Spam-Checker-Version: SpamAssassin 2.53-bugs.debian.org_2003_05_09 (

Package: libparagui1.0
Version: 1.0.2-1
Severity: serious

There was an error while trying to autobuild your package:

> Automatic build of libparagui1.0_1.0.2-1 on resume.rfc822.org by sbuild/mips 1.170
> Build started at 20030512-0131


> ** Using build dependencies supplied by package:
> Build-Depends: debhelper (>> 4.0.0), zip (>= 2.30-1), docbook-to-man, libexpat1-dev, libfreetype6-dev, libsdl1.2-dev (>= 1.2.5-1), zlib1g-dev, autotools-dev

The version of libtool used to build this source package is too old to
correctly support shared libraries for the Debian mips and mipsel
architectures.  At least version (1.4.2-7) and higher correctly supports
them.  You need to update all of the libtool related files by running
the following on your source tree:

	autoreconf --force

You may need to use the --install option as well.  You can also try the
individual commands needed yourself:

	libtoolize --force --copy
	automake -a

autoheader may not be needed, and you may need to use versioned binaries
(autoconf2.13, automake-1.{4,5,6,7}, aclocal-1.{4,5,6,7}, etc)

The correct 'configure' script will have output that looks like this:
# This must be Linux ELF.
  case $host_cpu in
  alpha* | hppa* | i*86 | mips | mipsel | powerpc* | sparc* | ia64* )
    lt_cv_deplibs_check_method=pass_all ;;

It is important that both mips and mipsel are listed in the configure script
Older versions of libtool used a file_magic check for the pattern
file_magic ELF [0-9][0-9]*-bit [LM]SB (shared object|dynamic lib )

The output of file(1) on a shared library on MIPS does not match this
regular expression, however.  Earlier versions of file had been
modified to match this regular expression, but the latest version uses
the same output as upstream once again.  The file check often causes
problems, and results on a build-dep on file that you might not
otherwise be aware of.  The new method doesn't need file(1) at all,
and is far less fragile, so it is best to upgrade the configure script
with proper mips support.

Received: (at 193023-close) by bugs.debian.org; 12 May 2003 23:23:36 +0000
>From katie@auric.debian.org Mon May 12 18:23:36 2003
Return-path: <katie@auric.debian.org>
Received: from auric.debian.org [] (mail)
	by master.debian.org with esmtp (Exim 3.12 1 (Debian))
	id 19FMdr-0001Hr-00; Mon, 12 May 2003 18:23:35 -0500
Received: from katie by auric.debian.org with local (Exim 3.35 1 (Debian))
	id 19FMYE-0006KS-00; Mon, 12 May 2003 19:17:46 -0400
From: Aurelien Jarno <aurel32@debian.org>
To: 193023-close@bugs.debian.org
X-Katie: $Revision: 1.34 $
Subject: Bug#193023: fixed in libparagui1.0 1.0.2-2
Message-Id: <E19FMYE-0006KS-00@auric.debian.org>
Sender: Archive Administrator <katie@auric.debian.org>
Date: Mon, 12 May 2003 19:17:46 -0400
Delivered-To: 193023-close@bugs.debian.org

We believe that the bug you reported is fixed in the latest version of
libparagui1.0, which is due to be installed in the Debian FTP archive:

  to pool/main/libp/libparagui1.0/libparagui1.0-dev_1.0.2-2_i386.deb
  to pool/main/libp/libparagui1.0/libparagui1.0_1.0.2-2.diff.gz
  to pool/main/libp/libparagui1.0/libparagui1.0_1.0.2-2.dsc
  to pool/main/libp/libparagui1.0/libparagui1.0_1.0.2-2_i386.deb
  to pool/main/libp/libparagui1.0/paragui-themes_1.0.2-2_i386.deb

A summary of the changes between this version and the previous one is

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to 193023@bugs.debian.org,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
Aurelien Jarno <aurel32@debian.org> (supplier of updated libparagui1.0 package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing ftpmaster@debian.org)

Hash: SHA1

Format: 1.7
Date: Tue, 13 May 2003 00:38:57 +0200
Source: libparagui1.0
Binary: libparagui1.0 paragui-themes libparagui1.0-dev
Architecture: source i386
Version: 1.0.2-2
Distribution: unstable
Urgency: medium
Maintainer: Debian QA Group <packages@qa.debian.org>
Changed-By: Aurelien Jarno <aurel32@debian.org>
 libparagui1.0 - a real crossplatform widget set based on SDL
 libparagui1.0-dev - Development files for the widget set library
 paragui-themes - Standard themes for the widget set library
Closes: 143762 193023
 libparagui1.0 (1.0.2-2) unstable; urgency=medium
   * Changed definition of PG_TimerID from Uint32 to int* (closes:
   * Run autoreconf --force in the source tree (closes: bug#193023).
 f690e44ae0116c4482fdc938e0476a79 732 devel optional libparagui1.0_1.0.2-2.dsc
 9389e0947989908920f7c21859b76cfc 40710 devel optional libparagui1.0_1.0.2-2.diff.gz
 8ddebcbb9c82e245c170f910d38e6411 199784 devel optional libparagui1.0_1.0.2-2_i386.deb
 f5141d9576d40d7313bd9483e76ff91b 348532 devel optional libparagui1.0-dev_1.0.2-2_i386.deb
 aa81452487e2b6b36817839c18da20a6 211170 devel optional paragui-themes_1.0.2-2_i386.deb

Version: GnuPG v1.2.1 (GNU/Linux)


Reply to: