[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#177574: python-tal: Should conflict with python2.1-tal (<= 1.5.0)

Package: python-tal
Version: 1.4.1-2
Severity: important

python-tal 1.5.0-4 installs /usr/share/doc/python-tal, which is also
installed by the stable package python2.1-tal (1.4.1-2). python-tal
should hence conflict with python2.1-tal (<=1.4.1-2), so that the
conflicting package is removed. Without that conflict, the upgrade fails
with this error:

Preparing to replace python-tal 1.4.1-2 (using .../python-tal_1.5.0-4_all.deb) ...
Unpacking replacement python-tal ...
dpkg: error processing /var/cache/apt/archives/python-tal_1.5.0-4_all.deb (--unpack):
 trying to overwrite `/usr/share/doc/python-tal', which is also in package python2.1-tal
Errors were encountered while processing:
E: Sub-process /usr/bin/dpkg returned an error code (1)


-- System Information
Debian Release: 3.0
Architecture: i386
Kernel: Linux clapton 2.4.19-686 #1 Mon Nov 18 23:59:03 EST 2002 i686
Locale: LANG=de_DE.ISO-8859-1, LC_CTYPE=de_DE@euro

Versions of packages python-tal depends on:
pn  python (<< 2.2)                          Not found.
ii  python2.1-tal                 1.4.1-2    Template Attribute Language

Reply to: