[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#162375: marked as done (FTBFS: Build failure of libg++27 on i386)

Your message dated Tue, 08 Oct 2002 02:47:22 -0400
with message-id <E17yo9K-0007Hq-00@auric.debian.org>
and subject line Bug#162375: fixed in libg++27
has caused the attached Bug report to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what I am
talking about this indicates a serious mail system misconfiguration
somewhere.  Please contact me immediately.)

Debian bug tracking system administrator
(administrator, Debian Bugs database)

Received: (at submit) by bugs.debian.org; 26 Sep 2002 01:23:12 +0000
>From dancer@netfort.gr.jp Wed Sep 25 20:23:12 2002
Return-path: <dancer@netfort.gr.jp>
Received: from mikilab.doshisha.ac.jp [] 
	by master.debian.org with esmtp (Exim 3.12 1 (Debian))
	id 17uNN1-0007o8-00; Wed, 25 Sep 2002 20:23:11 -0500
Received: from atoron.work.isl.doshisha.ac.jp (localhost [])
	by mikilab.doshisha.ac.jp (8.9.3/3.7W) with SMTP id KAA02355
	for <submit@bugs.debian.org>; Thu, 26 Sep 2002 10:22:40 +0900
X-Authentication-Warning: mikilab.doshisha.ac.jp: Host localhost [] claimed to be atoron.work.isl.doshisha.ac.jp
Date: Thu, 26 Sep 2002 10:22:55 +0900
From: Junichi Uekawa <dancer@netfort.gr.jp>
To: submit bug tracking system <submit@bugs.debian.org>
Subject: FTBFS: Build failure of libg++27 on i386
Message-Id: <20020926102255.1fa14d72.dancer@netfort.gr.jp>
Organization: Netfort project
X-Mailer: Sylpheed version 0.8.3 (GTK+ 1.2.10; i386-debian-linux-gnu)
Mime-Version: 1.0
Content-Type: text/plain; charset=US-ASCII
Content-Transfer-Encoding: 7bit
Delivered-To: submit@bugs.debian.org

Package: libg++27

libg++27 fails to build from source on i386, when doing a binary-all build.

I am filing this bug to notify you that I failed to build your
package from source. It is a serious problem that your source does not 
build from source using the information provided in your control files,
and such a package should not be distributed in a stable Debian distribution.

This build was done using pbuilder package.

Build log follows:
install -g root -o root -m 644 ./libg++/libg++.a ./libstdc++/libstdc++.a\
ln -s ../../lib/libc5-compat/libg++.so.27.2.1    debian/tmp-devel/usr/i486-linuxlibc1/lib/libg++.so
ln -s ../../lib/libc5-compat/libstdc++.so.27.2.1 debian/tmp-devel/usr/i486-linuxlibc1/lib/libstdc++.so
cd libstdc++; cp cassert cctype cerrno cfloat ciso646 climits clocale cmath complex csetjmp csignal cstdarg cstddef cstdio cstdlib cstring ctime cwchar cwctype new stddef string exception stdexcept typeinfo algorithm deque list map queue set stack vector utility functional iterator memory numeric ../debian/tmp-devel/usr/i486-linuxlibc1/include/g++
cd libio; cp PlotFile.h SFile.h builtinbuf.h editbuf.h fstream.h indstream.h iomanip.h iostream.h istream.h ostream.h parsestream.h pfstream.h procbuf.h stdiostream.h stream.h streambuf.h strfile.h strstream.h ../debian/tmp-devel/usr/i486-linuxlibc1/include/g++
cp libstdc++{,/stl}/*.h libg++/src/*.h \
cp: will not overwrite just-created `debian/tmp-devel/usr/i486-linuxlibc1/include/g++/bool.h' with `libg++/src/bool.h'
make: *** [binary-devel] Error 1


dancer@debian.org  http://www.netfort.gr.jp/~dancer

Received: (at 162375-close) by bugs.debian.org; 8 Oct 2002 06:55:20 +0000
>From katie@auric.debian.org Tue Oct 08 01:55:20 2002
Return-path: <katie@auric.debian.org>
Received: from auric.debian.org [] (mail)
	by master.debian.org with esmtp (Exim 3.12 1 (Debian))
	id 17yoH1-00040m-00; Tue, 08 Oct 2002 01:55:19 -0500
Received: from katie by auric.debian.org with local (Exim 3.35 1 (Debian))
	id 17yo9K-0007Hq-00; Tue, 08 Oct 2002 02:47:22 -0400
From: Matej Vela <vela@debian.org>
To: 162375-close@bugs.debian.org
X-Katie: $Revision: 1.26 $
Subject: Bug#162375: fixed in libg++27
Message-Id: <E17yo9K-0007Hq-00@auric.debian.org>
Sender: Archive Administrator <katie@auric.debian.org>
Date: Tue, 08 Oct 2002 02:47:22 -0400
Delivered-To: 162375-close@bugs.debian.org

We believe that the bug you reported is fixed in the latest version of
libg++27, which is due to be installed in the Debian FTP archive:

  to pool/main/libg/libg++27/libg++27-altdev_2.7.2.1-18_i386.deb
  to pool/main/libg/libg++27/libg++27_2.7.2.1-18.diff.gz
  to pool/main/libg/libg++27/libg++27_2.7.2.1-18.dsc
  to pool/main/libg/libg++27/libg++27_2.7.2.1-18_i386.deb

A summary of the changes between this version and the previous one is

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to 162375@bugs.debian.org,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
Matej Vela <vela@debian.org> (supplier of updated libg++27 package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing ftpmaster@debian.org)

Hash: SHA1

Format: 1.7
Date: Sun,  6 Oct 2002 11:24:51 +0200
Source: libg++27
Binary: libg++27-altdev libg++27
Architecture: source i386
Distribution: unstable
Urgency: low
Maintainer: Debian QA Group <packages@qa.debian.org>
Changed-By: Matej Vela <vela@debian.org>
 libg++27   - The GNU C++ libraries (libc5 version).
 libg++27-altdev - The GNU C++ libraries (libc5 version).
Closes: 162375
 libg++27 ( unstable; urgency=low
   * QA upload.
   * debian/rules:
     - Placate cp sanity checks.  Closes: #162375.
     - Set SHELL to /bin/bash for brace expansion.
   * Remove /usr/doc links.
   * debian/postinst-shared: Call ldconfig only for `configure'.
   * debian/changelog: Remove obsolete Emacs local variables.
   * Conforms to Standards version 3.5.7.
 3546535ed81f72646240798d912bf6a2 600 oldlibs optional libg++27_2.7.2.1-18.dsc
 b2cc2aa91d6b9876b41c25ad3a5b6eb6 12795 oldlibs optional libg++27_2.7.2.1-18.diff.gz
 7f4144b3118f72c8f8431fe7092369e7 330670 oldlibs optional libg++27-altdev_2.7.2.1-18_i386.deb
 9547813b8a5003b86b2271087c5718a6 238500 oldlibs optional libg++27_2.7.2.1-18_i386.deb

Version: GnuPG v1.2.0 (GNU/Linux)


Reply to: