[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#99521: marked as done (elm-me+: Missing symlinks for some man pages)

Your message dated Sun, 29 Sep 2002 15:48:33 -0400
with message-id <E17vk3N-0005vL-00@auric.debian.org>
and subject line Bug#99521: fixed in elm-me+ 2.4pl25ME+99c-1
has caused the attached Bug report to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what I am
talking about this indicates a serious mail system misconfiguration
somewhere.  Please contact me immediately.)

Debian bug tracking system administrator
(administrator, Debian Bugs database)

Received: (at maintonly) by bugs.debian.org; 1 Jun 2001 18:03:29 +0000
>From cjwatson@auric.debian.org Fri Jun 01 13:03:29 2001
Return-path: <cjwatson@auric.debian.org>
Received: from auric.debian.org [] (mail)
	by master.debian.org with esmtp (Exim 3.12 1 (Debian))
	id 155tGh-0004fW-00; Fri, 01 Jun 2001 13:03:27 -0500
Received: from cjwatson by auric.debian.org with local (Exim 3.12 1 (Debian))
	id 155tGh-0001wv-00; Fri, 01 Jun 2001 14:03:27 -0400
From: Colin Watson <cjwatson@debian.org>
To: maintonly@bugs.debian.org
Subject: elm-me+: Missing symlinks for some man pages
Message-Id: <E155tGh-0001wv-00@auric.debian.org>
Sender: Colin Watson <cjwatson@auric.debian.org>
Date: Fri, 01 Jun 2001 14:03:27 -0400
Delivered-To: maintonly@bugs.debian.org

Package: elm-me+
Severity: normal


An upcoming release of Debian policy, version, contains an amendment
which clarifies the way man pages need to be installed.

Until now, packages could install /usr/share/man/man1/foo.1.gz with 'foo,
bar \- programs to do something' in the NAME section and have no
corresponding symbolic link from bar.1.gz (policy suggested using a symbolic
link, but wasn't clear that it's required), and our man program happened to
magically figure it out for itself and display the right man page when you
typed 'man bar'. However, guaranteeing that this would work even when you've
recently installed some new packages has a serious performance impact on
man, as it frequently has to go and look through the filesystem to update
its database.

Before woody's base system is frozen, I intend to remove this "feature" from
man-db, so that its performance is consistent and acceptable for a
reasonable number of people. It isn't a standard feature even among the
various man page browsers in Debian, let alone in other Linux distributions,
so there should be no compatibility problems. However, your package seems to
rely on it, so this bug is being filed to let you know that the way some of
your man pages are installed needs to be improved in order to work properly
in woody. All you need to do, if you already have, say, foo(1) and expect
bar(1) to work as well, is install a symbolic link to foo.1.gz as bar.1.gz
(.so links and hard links are also OK, though symlinks are recommended).

Here's a list of man pages and the names that don't appear anywhere in the

  usr/share/man/man1/frm.1.gz: nfrm

If the list looks odd, please check man(7) to see if the man page is
formatted properly. This output was generated by way of mandb, so if it's
confused then users will be too; if it turns out that it's done the wrong
thing, please reassign this bug to man-db so that I can fix it. I might not
have caught symlinks that are created in the postinst (say, using
alternatives); if that's the case, please close this bug.

Please see bug #94995 and policy 3.5.5 section 13.1 for more information,
and feel free to contact me if you need help.


Colin Watson, via a script

Received: (at 99521-close) by bugs.debian.org; 29 Sep 2002 19:55:35 +0000
>From katie@auric.debian.org Sun Sep 29 14:55:35 2002
Return-path: <katie@auric.debian.org>
Received: from auric.debian.org [] (mail)
	by master.debian.org with esmtp (Exim 3.12 1 (Debian))
	id 17vkAB-00077K-00; Sun, 29 Sep 2002 14:55:35 -0500
Received: from katie by auric.debian.org with local (Exim 3.35 1 (Debian))
	id 17vk3N-0005vL-00; Sun, 29 Sep 2002 15:48:33 -0400
From: Matej Vela <vela@debian.org>
To: 99521-close@bugs.debian.org
X-Katie: $Revision: 1.26 $
Subject: Bug#99521: fixed in elm-me+ 2.4pl25ME+99c-1
Message-Id: <E17vk3N-0005vL-00@auric.debian.org>
Sender: Archive Administrator <katie@auric.debian.org>
Date: Sun, 29 Sep 2002 15:48:33 -0400
Delivered-To: 99521-close@bugs.debian.org

We believe that the bug you reported is fixed in the latest version of
elm-me+, which is due to be installed in the Debian FTP archive:

  to pool/main/e/elm-me+/elm-me+_2.4pl25ME+99c-1.diff.gz
  to pool/main/e/elm-me+/elm-me+_2.4pl25ME+99c-1.dsc
  to pool/main/e/elm-me+/elm-me+_2.4pl25ME+99c-1_i386.deb
  to pool/main/e/elm-me+/elm-me+_2.4pl25ME+99c.orig.tar.gz

A summary of the changes between this version and the previous one is

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to 99521@bugs.debian.org,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
Matej Vela <vela@debian.org> (supplier of updated elm-me+ package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing ftpmaster@debian.org)

Hash: SHA1

Format: 1.7
Date: Sun, 29 Sep 2002 20:00:02 +0200
Source: elm-me+
Binary: elm-me+
Architecture: source i386
Version: 2.4pl25ME+99c-1
Distribution: unstable
Urgency: low
Maintainer: Debian QA Group <packages@qa.debian.org>
Changed-By: Matej Vela <vela@debian.org>
 elm-me+    - MIME & PGP-aware interactive mail reader [enhanced]
Closes: 82916 88887 95490 98494 99521 111792 122807 128027 134742 142195 144156
 elm-me+ (2.4pl25ME+99c-1) unstable; urgency=low
   * QA upload.
   * New upstream version:
     - Uses nl_langinfo(CODESET), making locale-to-charset mappings
       unnecessary (PL96).  Closes: #82916, #98494, #122807.
     - Fixes yes/no messages (PL96).  Closes: #95490.
     - Links nfrm.1 to frm.1 (PL96b).  Closes: #99521.
     - Compiles shared objects with `-fPIC' (PL97c).  Closes: #111792.
     - fastmail handles `-' as standard input (PL98c).  Closes: #142195.
     - No superfluous calls to stat(2) (PL99).  Closes: #134742.
   * Apply patches from <http://people.debian.org/~vela/elm-me+/>
     (upstream is busy, but expects to include them in PL100/PL101):
     - Disable RPATH for system directories.
     - Make man pages refer to /etc/elm-me+ for configuration files.
     - lib/expand.c: Expand `{etc}' as /etc/elm-me+.
     - MANIFEST: Add src/remailer.c.
     - doc/Makefile.SH: Use Configure values for man page substitutions to
       avoid substituting temporary directories.  Closes: #144156.
     - shared_libs/iconv/iconv.c: GNU libc 2.2 no longer uses const for
       iconv(3) args.
     - utils/elmcharset.c: Add a `-T' option to specify the elm.map.txt
       directory on installation.
     - shared_libs/tls/config: Check the system directories.
   * Switch from debstd to debhelper.
   * Switch from suidmanager to dpkg-statoverride.
   * Change priority to optional, catching up with the override file.
   * Remove build dependency on gawk, mawk is fine.
   * Replace groff build dependency with groff-base.
   * Enable OpenSSL support.
   * Configure:
     - Install man pages into /usr/share/man/man1, not /usr/share/man.
       Disable cat pages.  Closes: #128027.
     - Set default calendar file to ~/.calendar/calendar to be consistent
       with bsdmainutils.
     - Default to no DSN support.  Sendmail users can turn it on in elm.rc.
     - Support pgp5i.
     - Append version number to library names to placate dpkg-shlibdeps.
     - Remove build dependencies on ispell, mail-transport-agent, metamail,
       and lpr by hardcoding program paths.
   * hdrs/sysdefs.SH: Use /etc/elm-me+/elm.mimetypes rather than
     /etc/mime.types as elm-me+ expects different column ordering.
   * debian/postrm: Remove /etc/elm-me+ on purge to work around #59343.
     Closes: #88887.
   * debian/rules:
     - Symlink README.ME+.gz to changelog.gz as suggested in #82908.
     - Clean all files not listed in MANIFEST.
   * debian/README.Debian, debian/elm.rc:
     - Remove `to be removed later' section on upgrading from plain Elm
       (that was 5 years ago).
     - VISUAL support and special pager handling were dropped some time
       between 2.4pl25ME+39-1 and 2.4pl25ME+48-2.
     - Since PL68 the domain is determined using gethostbyname(3) rather
       than getdomainname(3), so NIS/YP users no longer need to set it
     - 2.4pl25ME+94-1 switched from flock to fcntl locking.
   * debian/changelog: Remove obsolete Emacs local variables.
   * Conforms to Standards version 3.5.7.
 bba29735e955046eb59f6428e2d004ca 631 mail optional elm-me+_2.4pl25ME+99c-1.dsc
 8674faceb38cbcfed7a68bb737227063 1248788 mail optional elm-me+_2.4pl25ME+99c.orig.tar.gz
 f55eee7b9c7912c0192ccf1eaec94dbc 16639 mail optional elm-me+_2.4pl25ME+99c-1.diff.gz
 3e81271a1b33e5210749267b91841e8e 782862 mail optional elm-me+_2.4pl25ME+99c-1_i386.deb

Version: GnuPG v1.2.0 (GNU/Linux)


Reply to: