[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#907900: hplip: Printing is not possible b/c of missing foomatic-rip-hplip filter



Package: hplip
Version: 3.17.10+repack0-5
Severity: important

Dear Maintainer,

I just bought an HP 3639 printer and wanted to use it. Configuring it via the
CUPS UI went fine : I use the suggested driver = HP Deskjet 3630 Series hpijs, 3.17.10 (color)

Unfortunately, nothing happens when I try to print, and the CUPS error log file
gives the following details:

E [03/Sep/2018:21:35:59 +0200] HP_DeskJet_3630_series: File \"/usr/lib/cups/filter/foomatic-rip-hplip\" not available: No such file or directory
E [03/Sep/2018:21:35:59 +0200] [Job 192] Unable to start filter "foomatic-rip-hplip" - Success.
E [03/Sep/2018:21:35:59 +0200] [Job 192] Stopping job because the scheduler could not execute a filter.

Having a look on HP suport site did not really helped me, since they just
suggest to drop the package, download the sources and compile. 

I really appreciate your help and time, please don't hesitate to ask for more
details.

Dimitri

-- Package-specific info:
Saving output in log file: /home/dimitri/hp-check.log

HP Linux Imaging and Printing System (ver. 3.17.10)
Dependency/Version Check Utility ver. 15.1

Copyright (c) 2001-15 HP Development Company, LP
This software comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to distribute it
under certain conditions. See COPYING file for more details.

Note: hp-check can be run in three modes:
1. Compile-time check mode (-c or --compile): Use this mode before compiling the HPLIP supplied tarball (.tar.gz or .run) to determine if the proper          
dependencies are installed to successfully compile HPLIP.                                                                                                     
2. Run-time check mode (-r or --run): Use this mode to determine if a distro supplied package (.deb, .rpm, etc) or an already built HPLIP supplied tarball has
the proper dependencies installed to successfully run.                                                                                                        
3. Both compile- and run-time check mode (-b or --both) (Default): This mode will check both of the above cases (both compile- and run-time dependencies).    

Check types:                                                                                                                                                  
a. EXTERNALDEP - External Dependencies                                                                                                                        
b. GENERALDEP - General Dependencies (required both at compile and run time)                                                                                  
c. COMPILEDEP - Compile time Dependencies                                                                                                                     
d. [All are run-time checks]                                                                                                                                  
PYEXT SCANCONF QUEUES PERMISSION                                                                                                                              

Status Types:
    OK
    MISSING       - Missing Dependency or Permission or Plug-in
    INCOMPAT      - Incompatible dependency-version or Plugin-version

warning: 2-buster/sid version is not supported. Using 2-9.1 versions dependencies to verify and install...

---------------
| SYSTEM INFO |
---------------

 Kernel: 4.17.0-3-amd64 #1 SMP Debian 4.17.17-1 (2018-08-18) GNU/Linux
 Host: keats
 Proc: 4.17.0-3-amd64 #1 SMP Debian 4.17.17-1 (2018-08-18) GNU/Linux
 Distribution: 2 buster/sid
 Bitness: 64 bit


-----------------------
| HPLIP CONFIGURATION |
-----------------------

HPLIP-Version: HPLIP 3.17.10
HPLIP-Home: /usr/share/hplip
warning: HPLIP-Installation: Auto installation is not supported for 2 distro  buster/sid version 

Current contents of '/etc/hp/hplip.conf' file:
# hplip.conf.  Generated from hplip.conf.in by configure.

[hplip]
version=3.17.10

[dirs]
home=/usr/share/hplip
run=/var/run
ppd=/usr/share/ppd/hplip/HP
ppdbase=/usr/share/ppd/hplip
doc=/usr/share/doc/hplip
html=/usr/share/doc/hplip-doc
icon=no
cupsbackend=/usr/lib/cups/backend
cupsfilter=/usr/lib/cups/filter
drv=/usr/share/cups/drv
bin=/usr/bin
apparmor=/etc/apparmor.d
# Following values are determined at configure time and cannot be changed.
[configure]
network-build=yes
libusb01-build=no
pp-build=yes
gui-build=yes
scanner-build=yes
fax-build=yes
dbus-build=yes
cups11-build=no
doc-build=yes
shadow-build=no
hpijs-install=yes
foomatic-drv-install=yes
foomatic-ppd-install=yes
foomatic-rip-hplip-install=no
hpcups-install=yes
cups-drv-install=yes
cups-ppd-install=no
internal-tag=3.17.10
restricted-build=no
ui-toolkit=qt5
qt3=no
qt4=no
qt5=yes
policy-kit=yes
lite-build=no
udev_sysfs_rules=no
hpcups-only-build=no
hpijs-only-build=no
apparmor_build=no


Current contents of '/var/lib/hp/hplip.state' file:
Plugins are not installed. Could not access file: No such file or directory

Current contents of '~/.hplip/hplip.conf' file:
[installation]
date_time = 09/03/18 22:13:23
version = 3.17.10


 <Package-name>        <Package-Desc>      <Required/Optional> <Min-Version> <Installed-Version> <Status>   <Comment>

-------------------------
| External Dependencies |
-------------------------

 error: cups          CUPS - Common Unix Printing System                           REQUIRED        1.1             -               INCOMPAT   'CUPS may not be installed or not running'
 gs                   GhostScript - PostScript and PDF language interpreter and previewer REQUIRED        7.05            9.22            OK         -
 xsane                xsane - Graphical scanner frontend for SANE                  OPTIONAL        0.9             0.999           OK         -
 scanimage            scanimage - Shell scanning program                           OPTIONAL        1.0             1.0.25          OK         -
 dbus                 DBus - Message bus system                                    REQUIRED        -               1.12.10         OK         -
 policykit            PolicyKit - Administrative policy framework                  OPTIONAL        -               0.105           OK         -
 network              network -wget                                                OPTIONAL        -               1.19.5          OK         -
 error: avahi-utils   avahi-utils                                                  OPTIONAL        -               -               MISSING    'avahi-utils needs to be installed'

------------------------
| General Dependencies |
------------------------

 error: libjpeg       libjpeg - JPEG library                                       REQUIRED        -               -               MISSING    'libjpeg needs to be installed'
 error: cups-devel    CUPS devel- Common Unix Printing System development files    REQUIRED        -               -               MISSING    'cups-devel needs to be installed'
 error: cups-image    CUPS image - CUPS image development files                    REQUIRED        -               -               MISSING    'cups-image needs to be installed'
 libpthread           libpthread - POSIX threads library                           REQUIRED        -               b'2.27'         OK         -
 error: libusb        libusb - USB library                                         REQUIRED        -               1.0             MISSING    'libusb needs to be installed'
 sane                 SANE - Scanning library                                      REQUIRED        -               -               OK         -
 error: sane-devel    SANE - Scanning library development files                    REQUIRED        -               -               MISSING    'sane-devel needs to be installed'
 error: libnetsnmp-devel libnetsnmp-devel - SNMP networking library development files REQUIRED        5.0.9           -               MISSING    'libnetsnmp-devel needs to be installed'
 libcrypto            libcrypto - OpenSSL cryptographic library                    REQUIRED        -               1.1.0           OK         -
 python3X             Python 2.2 or greater - Python programming language          REQUIRED        2.2             3.6.6           OK         -
 error: python3-notify2 Python libnotify - Python bindings for the libnotify Desktop notifications OPTIONAL        -               -               MISSING    'python3-notify2 needs to be installed'
 error: python3-pyqt4-dbus PyQt 4 DBus - DBus Support for PyQt4                         OPTIONAL        4.0             -               MISSING    'python3-pyqt4-dbus needs to be installed'
 error: python3-pyqt4 PyQt 4- Qt interface for Python (for Qt version 4.x)         REQUIRED        4.0             -               MISSING    'python3-pyqt4 needs to be installed'
 python3-dbus         Python DBus - Python bindings for DBus                       REQUIRED        0.80.0          1.2.8           OK         -
 python3-xml          Python XML libraries                                         REQUIRED        -               2.2.6           OK         -
 error: python3-devel Python devel - Python development files                      REQUIRED        2.2             3.6.6           MISSING    'python3-devel needs to be installed'
 python3-pil          PIL - Python Imaging Library (required for commandline scanning with hp-scan) OPTIONAL        -               1.1.7           OK         -
 python3-reportlab    Reportlab - PDF library for Python                           OPTIONAL        2.0             3.5.6           OK         -

--------------
| COMPILEDEP |
--------------

 error: libtool       libtool - Library building support services                  REQUIRED        -               -               MISSING    'libtool needs to be installed'
 gcc                  gcc - GNU Project C and C++ Compiler                         REQUIRED        -               8.2.0           OK         -
 make                 make - GNU make utility to maintain groups of programs       REQUIRED        3.0             4.2.1           OK         -

---------------------
| Python Extentions |
---------------------

 cupsext              CUPS-Extension                                               REQUIRED        -               3.17.10         OK         -
 hpmudext             IO-Extension                                                 REQUIRED        -               3.17.10         OK         -

----------------------
| Scan Configuration |
----------------------

'/etc/sane.d/dll.d/hpaio' not found.
 hpaio                HPLIP-SANE-Backend                                           REQUIRED        -               3.17.10         OK         'hpaio found in /etc/sane.d/dll.conf'
 scanext              Scan-SANE-Extension                                          REQUIRED        -               3.17.10         OK         -

------------------------------
| DISCOVERED SCANNER DEVICES |
------------------------------

device `hpaio:/usb/DeskJet_3630_series?serial=CN86H6H25T0658' is a Hewlett-Packard DeskJet_3630_series all-in-one


--------------------------
| DISCOVERED USB DEVICES |
--------------------------

  Device URI                                         Model                          
  -------------------------------------------------  -------------------------------
  hp:/usb/DeskJet_3630_series?serial=CN86H6H25T0658  HP DeskJet 3630 series         

---------------------------------
| INSTALLED CUPS PRINTER QUEUES |
---------------------------------


HP_DeskJet_3630_series
----------------------
Type: Unknown
Device URI: usb://HP/DeskJet%203630%20series?serial=CN86H6H25T0658&interface=1
PPD: /etc/cups/ppd/HP_DeskJet_3630_series.ppd
warning: Failed to read /etc/cups/ppd/HP_DeskJet_3630_series.ppd ppd file
PPD Description: 
Printer status: printer HP_DeskJet_3630_series is idle.  enabled since Mon Sep  3 21:35:59 2018
	File "/usr/lib/cups/filter/foomatic-rip-hplip" not available: No such file or directory
warning: Printer is not HPLIP installed. Printers must use the hp: or hpfax: CUPS backend for HP-Devices.


--------------
| PERMISSION |
--------------

USB             None                           Required        -        -        OK       Node:'/dev/bus/usb/003/005' Perm:'  root  lp rw- rw- rw- rw- rw- r--'

-----------
| SUMMARY |
-----------

Missing Required Dependencies
-----------------------------
error: 'cups' package is missing or 'cups' service is not running.
error: 'libcups2' package is missing/incompatible 
error: 'libjpeg62-turbo-dev' package is missing/incompatible 
error: 'libcups2-dev' package is missing/incompatible 
error: 'cups-bsd' package is missing/incompatible 
error: 'cups-client' package is missing/incompatible 
error: 'libcupsimage2' package is missing/incompatible 
error: 'libcupsimage2-dev' package is missing/incompatible 
error: 'libusb-1.0.0-dev' package is missing/incompatible 
error: 'libsane-dev' package is missing/incompatible 
error: 'libsnmp-dev' package is missing/incompatible 
error: 'snmp' package is missing/incompatible 
error: 'python3-pyqt4' package is missing/incompatible 
error: 'gtk2-engines-pixbuf' package is missing/incompatible 
error: 'python3-dev' package is missing/incompatible 
error: 'libtool' package is missing/incompatible 
error: 'libtool-bin' package is missing/incompatible 

Missing Optional Dependencies
-----------------------------
error: 'avahi-utils' package is missing/incompatible 
error: 'python3-notify2' package is missing/incompatible 
error: 'python3-dbus.mainloop.qt' package is missing/incompatible 

Total Errors: 13
Total Warnings: 1


Done.

-- System Information:
Debian Release: buster/sid
  APT prefers testing
  APT policy: (990, 'testing'), (500, 'unstable'), (500, 'stable')
Architecture: amd64 (x86_64)
Foreign Architectures: i386

Kernel: Linux 4.17.0-3-amd64 (SMP w/4 CPU cores)
Locale: LANG=fr_FR.utf8, LC_CTYPE=fr_FR.utf8 (charmap=UTF-8), LANGUAGE=fr_FR.utf8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash
Init: systemd (via /run/systemd/system)
LSM: AppArmor: enabled

Versions of packages hplip depends on:
ii  adduser                3.117
ii  cups                   2.2.8-5
ii  hplip-data             3.17.10+repack0-5
ii  libc6                  2.27-5
ii  libcups2               2.2.8-5
ii  libdbus-1-3            1.12.10-1
ii  libhpmud0              3.17.10+repack0-5
ii  libsane                1.0.25-4.1
ii  libsane-hpaio          3.17.10+repack0-5
ii  libsnmp30              5.7.3+dfsg-3
ii  libusb-1.0-0           2:1.0.22-2
ii  lsb-base               9.20170808
ii  printer-driver-hpcups  3.17.10+repack0-5
ii  python3                3.6.5-3
ii  python3-dbus           1.2.8-2+b1
ii  python3-gi             3.28.3-1
ii  python3-pexpect        4.6.0-1
ii  python3-pil            5.2.0-2
ii  python3-reportlab      3.5.6-1
ii  wget                   1.19.5-1
ii  xz-utils               5.2.2-1.3

Versions of packages hplip recommends:
ii  avahi-daemon                  0.7-4
ii  policykit-1                   0.105-21
ii  printer-driver-postscript-hp  3.17.10+repack0-5
ii  sane-utils                    1.0.25-4.1

Versions of packages hplip suggests:
pn  hplip-doc              <none>
pn  hplip-gui              <none>
pn  python3-notify2        <none>
pn  system-config-printer  <none>

-- no debconf information
---
Dimitri Chausson


Reply to: