[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: G5 owners, please test ... Re: ppc64 pseries 2.6.11-2 .deb kernel available.



On Fri, Jun 03, 2005 at 12:28:08AM +0100, Paul Brossier wrote:
> On Thu, Jun 02, 2005 at 11:34:36PM +0200, Sven Luther wrote:
> > On Sat, May 28, 2005 at 04:15:39PM +0200, Sven Luther wrote:
> > > Hello all,
> > > 
> > > Thanks to the great job of Jeff Bailey and Matthias Klose, who provided a set
> > > of gcc-3.4/glibc-2.3.5 based biarch toolchain, i have managed to build a first
> > > ppc64 kernel package, which is available at :
> > > 
> > >   http://people.debian.org/~luther/ppc64
> > > 
> > > Altough obviously untested, as i don't have a ppc64 box, it should install
> > > over a normal sarge system, and run on all ppc64 boxes, from power3 RS6K ones
> > > to newer iseries, passing by all apple G5 macs, except for the older
> > > pre-power5 iseries. It is built without power4 optimization and in SMP mode
> > > only for now, since i want to get this flavour tested and investigated before
> > > multiplicating the different kernel images.
> > > 
> > > This kernel is *not* yet for production, since at least it will want a 64bit
> > > compiled procutils, to take care of 64bit process ids in /proc.
> > > 
> > > Future plans include integrating these kernels in etch, once the biarch
> > > toolchain makes it to it, and working on a ppc64 d-i, but first please test
> > > this kernel on as much as possible 64bit powerpc machines, and provide
> > > feedback to me.
> > 
> > So, none of you G5 powermac owners is willing to test this 64bit kernel, after
> > all the time folk have been requesting it ? 
> > 
> > I have had only two reports so far, one successful on a :
> > 
> >   pSeries 630, model 7028-6E4 
> > 
> > and one failed on a :
> > 
> >    POWER5 IBM iSeries (i5) model 9406-520
> > 
> > (probably due to missing LPAR support patches).
> > 
> > In any case, it should work just fine on G5 powermacs.
> 
> Yes it does. Just to be more precise, it runs fine on PowerBook7,2 but
> lacks fan control support.

Huh ? If you have a powerbook G5, i guess apple's legal department will be
going after you pretty soon for disclosing that fact :)

Seriously, the -pseries kernel above should *not* run on a G4 computer like
your powerbook.

> Now where can i find this toolchain? :-)

Ah, i have not yet uploaded it, but will try to do it this week-end.

Friendly,

Sven Luther



Reply to: