[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: How to get infrared and/or Nokia working

Hi Julien and everybody

Finally, irdadump is showing these:

19:40:11.620026 xid:cmd b9e67de2 > ffffffff S=6 s=3 (14)
19:40:11.710036 xid:cmd b9e67de2 > ffffffff S=6 s=4 (14)
19:40:11.800029 xid:cmd b9e67de2 > ffffffff S=6 s=5 (14)
19:40:11.880010 xid:rsp b9e67de2 < 0000dc28 S=6 s=5 Nokia 6100
hint=b125 [ PnP Modem Fax Telephony IrCOMM IrOBEX ] (27)
19:40:11.890052 xid:cmd b9e67de2 > ffffffff S=6 s=* lombi hint=0400 [
Computer ] (21)

But still no luck with gnokii.

I've tried with both
  cat /proc/sys/net/irda/max_baud_rate
  echo "57600" > /proc/sys/net/irda/max_baud_rate

irdadump showed correct output with both, gnokii did not work with either.

Here's what I get from gnokii:

with  model = 6100  in /root/.gnokiirc:

root@lombi root# xgnokii
Lockfile /var/lock/LCK..ttyS1 is stale. Overriding it..
GSM/FBUS init failed!
Xlib: unexpected async reply (sequence 0x3897)!

with  model = 6110:

root@lombi root# xgnokii
Lockfile /var/lock/LCK..ttyS1 is stale. Overriding it..

root@lombi root# gnokii --identify
GNOKII Version 0.5.2
Lockfile /var/lock/LCK..ttyS1 is stale. Overriding it..
Timeout: aborting command ``/usr/lib/gnokii/gnokii'' with signal 9
/usr/bin/gnokii: line 16: 28743 Getötet                 timeout

There's a  ./common/phones/nk6100.c in the debian sources,
root@lombi root# strings /usr/lib/libgnokii.so.1.0|grep 6100
root@lombi root# strings /usr/lib/libgnokii.so.1.0|grep 6110
Does that mean 6100 is supported or not?

I've never seen any other packet in irdadump output than those
already shown above (i.e. normal discovery activity).

At 8:37 Uhr +0100 26.10.2003, Julien BLACHE wrote:
 > b) anyone succeeded in using gnokii with a mac?

Yes, works fine. At least last I tried, which was some months ago with
a 2.4.20-benh kernel.

But you shouldn't use /dev/ttyS1. You should load the ircomm module
and use /dev/ircomm0.

Only for minicom, right? (or also for gnokii? I guess that no?)

The irda port on the mac can be used as a SIR device (what you're
currently doing), I think it could be used as a FIR device too but
there is currently no driver for that (assuming it's possible at all,
which I'm not sure).

Aren't you using a FIR driver, if you have
* irda-common/firdev: smc-ircc
in your irda-common configuration?

At 20:51 Uhr +0100 01.11.2003, Julien BLACHE wrote:
Here's what I answered when installing irda-common :

Here's my new config:
* irda-common/ttydev: /dev/ttyS1
* irda-common/aboutdoc:
* irda-common/enable: true
* irda-common/changes:
* irda-common/discovery: true
* irda-common/regen: true  <---how to change that?
* irda-common/dongle: none
  irda-common/firdev:  <----there was no possiblity to choose smc-ircc
* irda-common/selectdevice: serial

Where's the smc-ircc coming from that you are using?

Here are the only modules shown by lsmod that were loaded by my tests:
irtty                   7072   2  (autoclean)
irda                  101572   0  (autoclean) [irtty]

The device (ttydev) to use is the _serial_ device on which the IrDA
port is attached, so that would be /dev/ttyS1 and not /dev/ircomm0
(that you should use when you want to reach a device over the IrDA

(I know what a serial protocol looks like; I know a little bit about
talking to serial  devices on linux; now is ircomm implemented on top
of serial or vice versa or are they both implemented on top of
something else - i.e. what does the protocol look like that's
flashing the lights, normal serial or not?)

Use ps to see what options where passed to irattach. You should find
the serial device (/dev/ttyS1) and the discovery option (-s).

yep that's the case.

 > the above lines. /etc/init.d/irda restarts a new instance of
 irattach. /etc/init.d/irda stop does not terminate them. kill does

Yes, I've had this problem, however, I no longer experience that with
2.4.22-ben2 and an up-to-date unstable system (dunno which of the
kernel or userspace tools changed, but that doesn't happen anymore).

Running 2.4.22-ben1 and (+-) up-to-date unstable.

Non-commentedout contents of /root/.gnokiirc:
port = /dev/ttyS1
model = 6110
initlength = default
connection = irda
bindir = /usr/sbin/
use_locking = yes
serial_baudrate = 19200
smsc_timeout = 10
TELEPHONE = 12345678

Thanks for the endurance


Reply to: