[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Configuring XFree86 on PowerBook G3 Lombard (Bronze)

> I need your help:  I can't get Xserver to work on my PowerBook G3.
> (I'm using Woody.)

i recall several threads here about getting xfree86 working on lombard, the 
reassuring answer it that it does! and with acceleration ( if you are looking 
for a challenge. . see http://people.debian.org/~daenzer/ for the relevant 
dri-mach64 packages)

to begin with, the video chip is ati mach64, so the relevant bits of your 
xfree86 config should look something like

Section "Monitor"
	Identifier	"Lombard LCD"
	Option		"DPMS"
	HorizSync 	31.5-57.0
        VertRefresh 	50-70

Section "Device"
	Identifier		"Lombard ATI"
	Driver			"ati"
	ChipSet			"mach64"
	BusID			"PCI:0:17:0"
	Option "DMAMode"	"mmio"

Section "Screen"
	Identifier	"Screen0"
	Device		"Lombard ATI"
	Monitor		"Lombard LCD"
	DefaultDepth	16
	SubSection "Display"
		Depth		16
		Modes 		"1024x768" "800x600" "640x480"

> I've never used X before - This is my first time using Linux as a desktop.
> I've only used it in a server environment in the past.
> I've researched the video spec's at apple.com
> (http://docs.info.apple.com/article.html?artnum=43120) and by searching
> Google but wasn't able to find much of the information that the
> dpkg-reconfigure script (`dpkg-reconfigure xserver-xfree86`) is asking for.
> e.g., Driver, sync/refresh rates, mouse type, keyboard type, etc.
> I recall reading somewhere that the Lombard uses an ATI driver but can not
> find much else. Please help!
> Eric P.
> Sunnyvale, CA

Reply to: