[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: DRI not working with ATI Radeon M7

On Son, 2002-12-29 at 20:18, florian wrote:
> > > > (EE) RADEON(0): [dri] RADEONDRIScreenInit failed because of a version mismatch.
> > > > [dri] radeon.o kernel module version is 1.1.1 but version 1.2.1 or newer is needed.
> > > > [dri] Disabling DRI.
> > 
> > The version tells another story, you did rmmod the module after that,
> > didn't you? Or maybe the kernel has the DRM built in as well? That
> > scenario isn't handled intelligently yet unfortunately.
> yup. i rmmod the radeon module.. and i copied the dri one over the kernel
> one. so that should be okay. i also rebooted. but still no success.
> do i need to load any other module besides the radeon one? maybe agpgart?

No. Have you verified that no radeon DRM is built into the kernel?

Earthling Michel Dänzer (MrCooper)/ Debian GNU/Linux (powerpc) developer
XFree86 and DRI project member   /  CS student, Free Software enthusiast

Reply to: