[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Trying to get 2.2.19+3dfx+reiserfs


I have a StarMax 4000 (PMac 4400-like) with a coupla MacOS SCSI drives, a dedicated 30GB IDE for linux, and a 3dfx video card. The onboard ATI graphics are fubared due to some partially fried VRAM.

I am a PowerPC Debian newbie, but have used Macs since the SE and have installed Debian on an Athlon-ATA100-Nvidia-digital LCD-reiserfs-2.4.4kernel setup.

So, since my Mac was aging, I thought I'd switch it over to Linux and see if I can get some extra functionality out of it. What I would like to get is a kernel that can do 3dfx console and some sort of journaling file system.

I have tried 2.2.19 + 3dfx (works!) + reiserfs (doesn't!)
linux-2.4-paulus (3dfx doesn't, can't see if reiserfs does or not)
linux-2.4-benh    (same problem as paulus)

For the 2.2.19, the reiserfs patch applied without any problems. I recompiled the kernel with reiserfs support. Installed from source the reiserfsprogs-3.0.j-esafe. Made a reiserfs partition.

to /etc/fstab, I added:

/dev/hda5         /reiser        reiserfs    default     0 2

mount -a  returned that no valid reiserfs was found. Tried:

mount -t reiserfs /dev/hda5 /reiser

and got the same problem.

Is there anyway to tell if reiser was compiled into the kernel? cat /proc/???


Anthony Lau

Reply to: