[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Where is the mouse?

Christian wrote:
>I've got a Power Macintosh 8600/250 with ADB-mouse and ADB-keyboard.
>Where is the mouse? /dev/device...
>What type of mouse should I choose when I run gpmconfig? etc.
>How do I configure X? XF86Setup seems to be missing in the PowerPC-release.

I'm in a similar situation... I've been working on getting Debian set-up on
my iMac for the past few weeks now and... I'm... almost... there! At this
point, I've got XF86Config working and I can boot into X. However, my mouse
and keyboard don't work. I'm running 2.2.13 which I rsync'd from the stable
pmac tree.

First off, X won't recognize /dev/usbmouse when I start X. Following the
directions regarding 2.2.13 and X on www.imaclinux.net, I switched my
pointer to /dev/gpmdata. However, gpm won't recognize /dev/usbmouse which I
set-up as mknod /dev/usbmouse c 10 32. So, when I run gpmconfig, it can't
find my mouse. Anyone know what's going on here? I don't know where to find
info on the latest happenings with the kernel, so I'm hoping someone here
knows what the deal is with /dev/usbmouse and if it's a 2.2.13 problem.

As far as my keyboard goes, I don't have a clue as to what the problem is
there. I've tried disabling xkb in XF86Config, but I still don't get

Can anyone help me? Thanks!

**By the way, I downloaded console-data 1999.08.29-8 this evening and dpkg
gave me the response "bug: no keymaps described for architecture powerpc at
/var/lib/dpkg/info/console-date.config line 307". How do I report this?
This post good enough?

Nathan Olsen

"It is our nature to put all knowledge into context in order to tell
a story, and to re-create the world by this means."

                     --Edward O. Wilson, _Consilience_

Reply to: