[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: IMPORTANT : latest bash intall fails and bash is no more usable!!!

> (Reading database ... 21767 files and directories currently installed.)
> Preparing to replace bash 2.01.1-4.1 (using bash_2.02.1-1.4.deb) ...
> dpkg: warning - old pre-removal script killed by signal (Segmentation fault)
> dpkg - trying script from the new package instead ...
> dpkg: error processing bash_2.02.1-1.4.deb (--install):
>  subprocess new pre-removal script killed by signal (Segmentation fault)
> dpkg: error while cleaning up:
>  subprocess post-installation script killed by signal (Segmentation fault)
> Errors were encountered while processing:
>  bash_2.02.1-1.4.deb

Same here. I thought first it is the new libreadline, because libreadline installs
cleanly but bash not. 
I extracted it with dpkg -x bashxxxx.deb and copied the new bash to /bin. After
that all works again, also dpkg -i bashxxxx.deb!!! Wondering. 



Reply to: