[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#452925: marked as done (openoffice.org-core: path to sun java plugin is wrong)

Your message dated Wed, 20 Feb 2008 18:15:19 +0200
with message-id <47BC5217.7060400@debian.org>
and subject line Re: Bug#452925: The 2nd Debian Openoffice.org bug triage - bug #452925
has caused the Debian Bug report #452925,
regarding openoffice.org-core: path to sun java plugin is wrong
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact owner@bugs.debian.org

452925: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=452925
Debian Bug Tracking System
Contact owner@bugs.debian.org with problems
--- Begin Message ---
Package: openoffice.org-core
Version: 1:2.3.0.dfsg-2
Severity: important

Dear all,

sun-java6-bin 6-03-2
sun-java6-fonts 6-03-2
sun-java6-jdk 6-03-2
sun-java6-jre 6-03-2
sun-java6-plugin 6-03-2

When going into Tools->Options->Java I see 2 JRE installed:
 o Sun Microsystems Inc. 1.6.0_03
 o Free Software Foundation 1.5.0
but none is selected. Furthermore, if I select one of them, click OK, and
reopen Tool->Options->Java the selection is again gone.

The problem is that the path seems to be wrong:

When starting oowriter I get 
	javaldx failed!
and when I call "Export" and select tex (LaTeX2e) I get a warning window
stating that I don't have a usable JRE installed. At the sametime I get
on the command line:
	[Java framework]sunjavaplugin.so could not load Java runtime library:

But this file does not exists, it should be

or MUCH better

I checked that creating a symbolic link
	/usr/lib/jvm/java-1.5.0-sun- -> java-6-sun
did fix the problem.

I would suggest that the Debian sun-java packages ship a symlink
	/usr/lib/jvm/java-sun -> /usr/lib/jvm/java-6-sun
	/usr/lib/jvm/java-6-sun -> ....
and all the progs use /usr/lib/jvm/java-sun as path ...

Thanks and all the best


Running a java needing command 

-- System Information:
Debian Release: lenny/sid
  APT prefers unstable
  APT policy: (500, 'unstable')
Architecture: i386 (i686)

Kernel: Linux 2.6.24-rc3 (SMP w/2 CPU cores; PREEMPT)
Locale: LANG=en_US.ISO-8859-15, LC_CTYPE=en_US.ISO-8859-15 (charmap=ISO-8859-15)
Shell: /bin/sh linked to /bin/bash

Versions of packages openoffice.org-core depends on:
ii  fontconfig              2.5.0-2          generic font configuration library
ii  libc6                   2.7-1            GNU C Library: Shared libraries
ii  libcairo2               1.4.10-1         The Cairo 2D vector graphics libra
ii  libcurl3-gnutls         7.17.1-1         Multi-protocol file transfer libra
ii  libdb4.5                4.5.20-11        Berkeley v4.5 Database Libraries [
ii  libexpat1               1.95.8-4         XML parsing C library - runtime li
ii  libfreetype6            2.3.5-1+b1       FreeType 2 font engine, shared lib
ii  libgcc1                 1:4.2.2-3        GCC support library
ii  libglib2.0-0            2.14.3-1         The GLib library of C routines
ii  libgstreamer-plugins-ba 0.10.15-2        GStreamer libraries from the "base
ii  libgstreamer0.10-0      0.10.15-1        Core GStreamer libraries and eleme
ii  libgtk2.0-0             2.12.1-3         The GTK+ graphical user interface 
ii  libhunspell-1.1-0       1.1.9-1          spell checker and morphological an
ii  libice6                 2:1.0.4-1        X11 Inter-Client Exchange library
ii  libicu36                3.6-10           International Components for Unico
ii  libjpeg62               6b-14            The Independent JPEG Group's JPEG 
ii  libldap2                2.1.30.dfsg-13.5 OpenLDAP libraries
ii  libneon27-gnutls        0.27.2-1         An HTTP and WebDAV client library 
ii  libnspr4-0d             4.7.0~1.9b1-1    NetScape Portable Runtime Library
ii  libnss3-0d              3.11.7-1         Network Security Service libraries
ii  libpam0g             Pluggable Authentication Modules l
ii  libpango1.0-0           1.18.3-1         Layout and rendering of internatio
ii  libportaudio2           19+svn20071022-2 Portable audio I/O - shared librar
ii  libsm6                  2:1.0.3-1+b1     X11 Session Management library
ii  libsndfile1             1.0.17-4         Library for reading/writing audio 
ii  libstartup-notification 0.9-1            library for program launch feedbac
ii  libstdc++6              4.2.2-3          The GNU Standard C++ Library v3
ii  libstlport4.6c2         4.6.2-3          STLport C++ class library
ii  libx11-6                2:1.0.3-7        X11 client-side library
ii  libxaw7                 2:1.0.4-1        X11 Athena Widget library
ii  libxext6                1:1.0.3-2        X11 miscellaneous extension librar
ii  libxinerama1            1:1.0.2-1        X11 Xinerama extension library
ii  libxml2                 2.6.30.dfsg-3    GNOME XML library
ii  libxrender1             1:0.9.4-1        X Rendering Extension client libra
ii  libxslt1.1              1.1.22-1         XSLT processing library - runtime 
ii  libxt6                  1:1.0.5-3        X11 toolkit intrinsics library
ii  openoffice.org-common   1:2.3.0.dfsg-3   OpenOffice.org office suite archit
ii  ttf-opensymbol          1:2.3.0.dfsg-3   The OpenSymbol TrueType font
ii  zlib1g                  1: compression library - runtime

openoffice.org-core recommends no packages.

Versions of packages openoffice.org-common depends on:
ii  dictionaries-common [open 0.90.0         Common utilities for spelling dict
ii  openoffice.org-style-andr 1:2.3.0.dfsg-3 Default symbol style for OpenOffic

Versions of packages openoffice.org-java-common depends on:
ii  bsh                       2.0b4-7        Java scripting environment (BeanSh
ii  libxalan2-java            2.7.0-5        XSL Transformations (XSLT) process
ii  libxerces2-java           2.9.0-1        Validating XML parser for Java wit
ii  openoffice.org-common     1:2.3.0.dfsg-3 OpenOffice.org office suite archit

Versions of packages openoffice.org-core is related to:
pn  firefox                <none>            (no description available)
pn  iceape-browser         <none>            (no description available)
ii  icedove               free/unbranded thunderbird mail/ne
ii  iceweasel             lightweight web browser based on M
ii  imagemagick            7: Image manipulation programs
pn  libsane                <none>            (no description available)
ii  libxinerama1           1:1.0.2-1         X11 Xinerama extension library
ii  libxrender1            1:0.9.4-1         X Rendering Extension client libra
ii  openoffice.org-filter- 1:2.3.0.dfsg-2    Legacy filters (e.g. StarOffice 5.
ii  pstoedit               3.45-1            PostScript and PDF files to editab

-- no debconf information

--- End Message ---
--- Begin Message ---
Version: 1:2.4.0~rc1-2

re-closing. Adding version info.

Norbert Preining wrote:
> On Mo, 18 Feb 2008, Lior Kaplan wrote:
>> Please reproduce your bug on an updated version (testing, unstable) and confirm it still exists, or close it as irrelevant for recent versions.
> I cannot reporduce it with the current version in sid, so I am closing
> this bug.
> Best wishes
> Norbert
> -------------------------------------------------------------------------------
> Dr. Norbert Preining <preining@logic.at>        Vienna University of Technology
> Debian Developer <preining@debian.org>                         Debian TeX Group
> gpg DSA: 0x09C5B094      fp: 14DF 2E6C 0307 BE6D AD76  A9C0 D2BF 4AA3 09C5 B094
> -------------------------------------------------------------------------------
> OBWESTRY (abs.n.)
> Bloody-minded determination on part of a storyteller to continue a
> story which both the teller and the listeners know has become
> desperately tedious.
> 			--- Douglas Adams, The Meaning of Liff

Lior Kaplan

GPG fingerprint:
C644 D0B3 92F4 8FE4 4662  B541 1558 9445 99E8 1DA0

--- End Message ---

Reply to: