[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#582943: marked as done (camlp5: FTBFS with OCaml 3.12: inconsistent assumptions over interface Warnings)

Your message dated Tue, 15 Mar 2011 23:42:40 +0100
with message-id <4D7FEB60.105@debian.org>
and subject line Re: Bug#582943: camlp5: FTBFS with OCaml 3.12: inconsistent assumptions over interface Warnings
has caused the Debian Bug report #582943,
regarding camlp5: FTBFS with OCaml 3.12: inconsistent assumptions over interface Warnings
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact owner@bugs.debian.org

582943: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=582943
Debian Bug Tracking System
Contact owner@bugs.debian.org with problems
--- Begin Message ---
Package: camlp5
Version: 5.14-1+3.12.0+dev23+10396+1
Severity: normal
User: debian-ocaml-maint@lists.debian.org
Usertags: ocaml312-ftbfs


While rebuilding all packages with a SVN snapshot of OCaml (version
3.12.0+dev23, revision 10396), your package failed to build on amd64.

Relevant part:
> ocamlc -warn-error A -I ../main -I ../boot -I ../ocaml_stuff/3.12.0/utils -I ../ocaml_stuff/3.12.0/parsing -I ../ocaml_stuff/3.12.0/typing -I ../ocaml_stuff/3.12.0/toplevel -c -impl camlp5_top.ppo
> File "camlp5_top.ml", line 1, characters 0-1:
> Error: The files ../ocaml_stuff/3.12.0/parsing/parsetree.cmi
>        and /usr/lib/ocaml/toploop.cmi make inconsistent assumptions
>        over interface Warnings
> make[3]: *** [camlp5_top.cmo] Error 2
> make[3]: Leaving directory `/tmp/camlp5-5.14/top'
> make[2]: *** [out] Error 2
> make[2]: Leaving directory `/tmp/camlp5-5.14'
> make[1]: *** [world.opt] Error 2

The full build log is available at:

Copying warnings.mli from OCaml sources solves the problem. I guess we
should wait for a "more official" release of OCaml 3.12.0 before fixing

Best regards,


-- System Information:
Debian Release: squeeze/sid
  APT prefers testing
  APT policy: (990, 'testing'), (500, 'unstable'), (1, 'experimental')
Architecture: amd64 (x86_64)

Kernel: Linux 2.6.32-5-amd64 (SMP w/4 CPU cores)
Locale: LANG=fr_FR.UTF-8, LC_CTYPE=fr_FR.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash

Versions of packages camlp5 depends on:
ii  libc6              2.10.2-6              Embedded GNU C Library: Shared lib
ii  ocaml-compiler-lib 3.12.0~0dev23+10396-1 OCaml interpreter and standard lib
ii  ocaml-nox [ocaml-n 3.12.0~0dev23+10396-1 ML implementation with a class-bas

camlp5 recommends no packages.

Versions of packages camlp5 suggests:
ii  ocaml-findlib          1.2.5+debian-1+b1 management tool for OCaml librarie

-- no debconf information

--- End Message ---
--- Begin Message ---
Version: 6.02.1-1


--- End Message ---

Reply to: