[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#323963: marked as done (advi: segfault or fatal error when scaling display)

Your message dated Mon, 15 Mar 2010 23:02:12 +0000
with message-id <E1NrJIa-0007se-Dq@ries.debian.org>
and subject line Bug#323963: fixed in advi 1.9-1
has caused the Debian Bug report #323963,
regarding advi: segfault or fatal error when scaling display
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact owner@bugs.debian.org

323963: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=323963
Debian Bug Tracking System
Contact owner@bugs.debian.org with problems
--- Begin Message ---
Package: advi
Version: 1.6.0-6
Severity: normal

When I launch 'advi' without arguments to display the help file
/usr/lib/advi/splash.dvi, the program crashes when I press '<' or '>'
to resize the text.

This happens nearly every time I press those keys, but it also worked
correctly once.

It seems that when I press '<' it terminates with this output:

  Fatal error when running: Xlib error: BadPixmap (invalid Pixmap parameter)

or sometimes segfaults with

  Warning: Graphics.Graphic_failure("Xlib error: BadPixmap (invalid Pixmap parameter)")

However when I press '>', it terminates with a different message:

  Fatal error when running: Xlib error: BadDrawable (invalid Pixmap or Window parameter)
I tried this on two systems, both i386 running Debian testing with
some packages from unstable.

-- System Information:
Debian Release: testing/unstable
  APT prefers testing
  APT policy: (990, 'testing'), (500, 'unstable'), (500, 'stable'), (1, 'experimental')
Architecture: i386 (i686)
Shell:  /bin/sh linked to /bin/bash
Kernel: Linux 2.6.12-kelev
Locale: LANG=sv_SE.UTF-8, LC_CTYPE=sv_SE.UTF-8 (charmap=UTF-8)

Versions of packages advi depends on:
ii  gs                       8.15-2          Transitional package
ii  gs-esp [gs]              7.07.1-9        The Ghostscript PostScript interpr
ii  gs-gpl [gs]              8.15-2          The GPL Ghostscript PostScript int
ii  libc6                    2.3.5-3         GNU C Library: Shared libraries an
ii  libfreetype6             2.1.7-2.4       FreeType 2 font engine, shared lib
ii  libice6                  4.3.0.dfsg.1-14 Inter-Client Exchange library
ii  libjpeg62                6b-10           The Independent JPEG Group's JPEG 
ii  libpng12-0               1.2.8rel-1      PNG library - runtime
ii  libsm6                   4.3.0.dfsg.1-14 X Window System Session Management
ii  libtiff4                 3.7.3-1         Tag Image File Format (TIFF) libra
ii  libungif4g               4.1.3-3         shared library for GIF images (run
ii  libx11-6                 4.3.0.dfsg.1-14 X Window System protocol client li
ii  libxext6                 4.3.0.dfsg.1-14 X Window System miscellaneous exte
ii  libxpm4                  4.3.0.dfsg.1-14 X pixmap library
ii  tetex-bin                2.0.2-30        The teTeX binary files
ii  xlibs                    4.3.0.dfsg.1-14 X Keyboard Extension (XKB) configu
ii  zlib1g                   1:1.2.2-4       compression library - runtime

advi recommends no packages.

-- no debconf information

--- End Message ---
--- Begin Message ---
Source: advi
Source-Version: 1.9-1

We believe that the bug you reported is fixed in the latest version of
advi, which is due to be installed in the Debian FTP archive:

  to main/a/advi/advi-examples_1.9-1_all.deb
  to main/a/advi/advi_1.9-1.debian.tar.gz
  to main/a/advi/advi_1.9-1.dsc
  to main/a/advi/advi_1.9-1_amd64.deb
  to main/a/advi/advi_1.9.orig.tar.gz

A summary of the changes between this version and the previous one is

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to 323963@bugs.debian.org,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
Ralf Treinen <treinen@debian.org> (supplier of updated advi package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing ftpmaster@debian.org)

Hash: SHA1

Format: 1.8
Date: Mon, 15 Mar 2010 22:03:48 +0100
Source: advi
Binary: advi advi-examples
Architecture: source amd64 all
Version: 1.9-1
Distribution: experimental
Urgency: low
Maintainer: Debian OCaml Maintainers <debian-ocaml-maint@lists.debian.org>
Changed-By: Ralf Treinen <treinen@debian.org>
 advi       - an active DVI previewer and presenter
 advi-examples - example presentations for Active-DVI (advi)
Closes: 323963 452044
 advi (1.9-1) experimental; urgency=low
   * New upstream version. This version closes a bug concerning embedded
     postscript images (closes: #452044) and with the scaling of the display
     (closes: #323963).
   * Upstream distributes again the examples/ subtree, install it instead
     of our old copy in debian/examples-source. Remove from
     debian/examples-source the old copies of examples and test/.
   * patch doc-without-htmlc: do not call htmlc for building the doc
   * patch examples-no-check: add phony check target in examples/Makefile
     since this is called recursively on all subdirs from the toplevel
   * Dependency on ghostscript: >= 7.05
   * Build-dependencies: put back some dependencies since upstream makefile
     does again rebuild the doc: hevea, texlive-latex-base, texlive-pstricks,
     texlive-latex-recommended, texlive-pictures.
   * patch use-ghostscript: make configure believe that ghostscript is installed
     at compilation time.
   * debian/rules: also make the splash.dvi documents in doc/
   * Install doc/{splash,scratch_draw_splash,scratch_write_splash}.dvi files
     into /usr/share/advi
   * debian/control: Updated location of upstream homepage
   * debian/watch: put new domain (advi.inria.fr)
 75602d31f2f758c6d25d5a3d0fd85b00e3f30ab1 1625 advi_1.9-1.dsc
 059e5404d4a38aed1f267c3e9a40611908114940 8512355 advi_1.9.orig.tar.gz
 054ba52fb419ea316dee4c20f6de1ab8dc14482b 25211 advi_1.9-1.debian.tar.gz
 042ba9b106c6911f02f20422bb89fd1fcd6f77bd 5621388 advi_1.9-1_amd64.deb
 4c68f35c23d04bbc9b9e4e140b4969eaa8d915d4 3350180 advi-examples_1.9-1_all.deb
 a17975c77f6b908a526894067609f2384babde8a8d568672e253f72591d5d1cd 1625 advi_1.9-1.dsc
 fc1ce772b3ebc3f7cded12bd8b805108b71aac897bcf0f0d19f13b547c68b1f6 8512355 advi_1.9.orig.tar.gz
 3ec5ff8fbc5518e5dbff93600e65b442a52047ffd49a68b7d538bfc0c6c748cd 25211 advi_1.9-1.debian.tar.gz
 67416efba30d287200754086f5c13f3cb21accdafb150d950c296ec4b407a0c8 5621388 advi_1.9-1_amd64.deb
 f880298315000e5acf93b80fdca0c3624edcf16e7c82704554e26f8647dee914 3350180 advi-examples_1.9-1_all.deb
 75160a3be456229fad9b5a0e3e42b83a 1625 tex optional advi_1.9-1.dsc
 42fe60dc65eb3048d0fb4789db1ca05c 8512355 tex optional advi_1.9.orig.tar.gz
 93d31a977e99679c5604c6bd3802b209 25211 tex optional advi_1.9-1.debian.tar.gz
 d75c2cf3c9e0bb1db70b8026b1aa6b79 5621388 tex optional advi_1.9-1_amd64.deb
 36134e56f5451366ebf20b4a36f4ac6b 3350180 tex optional advi-examples_1.9-1_all.deb

Version: GnuPG v1.4.10 (GNU/Linux)


--- End Message ---

Reply to: