[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#532771: marked as done (pkglab: version specification needs single quote for versions)

Your message dated Wed, 17 Jun 2009 07:55:00 +0000
with message-id <E1MGpz2-0001JR-2w@ries.debian.org>
and subject line Bug#532771: fixed in pkglab 1.4.2-1
has caused the Debian Bug report #532771,
regarding pkglab: version specification needs single quote for versions
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact owner@bugs.debian.org

532771: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=532771
Debian Bug Tracking System
Contact owner@bugs.debian.org with problems
--- Begin Message ---
Package: pkglab
Version: 1.4.1-1
Severity: normal

I was browsing pkglab documentation /usr/share/doc/pkglab/pkglab.html
though the version specification example doesn't seem to work:

> select([. kde (>= 5.2) .]) 
Exception: Interpreter.Sorry("Can't find unit \"5.2\"")

while with single quote it does

> select([. kde (>= '5.2) .])
{ }

am I missing something obvious or the syntax has changed? (the same
error is reported also in #help:

  [.unit(operator version).]    Version specification (e.g. [.kde (>= 5.2).])
                (version part is optional)

also note that without version specification trailing space is
compulsory though the usage seems to suggest differently:

> [.cdbs.]  
Exception: Interpreter.Parse_error(7, 8, "Syntax error")
> [.cdbs .]
[. cdbs .]
> [. cdbs.]
Exception: Interpreter.Parse_error(8, 9, "Syntax error")


-- System Information:
Debian Release: squeeze/sid
  APT prefers unstable
  APT policy: (990, 'unstable')
Architecture: amd64 (x86_64)

Kernel: Linux (SMP w/2 CPU cores)
Locale: LANG=en_US.UTF-8, LC_CTYPE=en_US.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/bash

Versions of packages pkglab depends on:
ii  libbz2-1.0             1.0.5-2           high-quality block-sorting file co
ii  libc6                  2.9-13            GNU C Library: Shared libraries
ii  libgdbm3               1.8.3-4           GNU dbm database routines (runtime
ii  libpcre3               7.8-2             Perl 5 Compatible Regular Expressi
ii  libpopt0               1.14-4            lib for parsing cmdline parameters
ii  librpm4.4             RPM shared library
ii  zlib1g                 1: compression library - runtime

pkglab recommends no packages.

Versions of packages pkglab suggests:
ii  ceve                          1.3-1      utility to parse package dependenc

-- no debconf information

--- End Message ---
--- Begin Message ---
Source: pkglab
Source-Version: 1.4.2-1

We believe that the bug you reported is fixed in the latest version of
pkglab, which is due to be installed in the Debian FTP archive:

  to pool/main/p/pkglab/edos-distcheck_1.4.2-1_amd64.deb
  to pool/main/p/pkglab/pkglab_1.4.2-1.diff.gz
  to pool/main/p/pkglab/pkglab_1.4.2-1.dsc
  to pool/main/p/pkglab/pkglab_1.4.2-1_amd64.deb
  to pool/main/p/pkglab/pkglab_1.4.2.orig.tar.gz

A summary of the changes between this version and the previous one is

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to 532771@bugs.debian.org,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
Ralf Treinen <treinen@debian.org> (supplier of updated pkglab package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing ftpmaster@debian.org)

Hash: SHA1

Format: 1.8
Date: Tue, 16 Jun 2009 20:14:37 +0200
Source: pkglab
Binary: pkglab edos-distcheck
Architecture: source amd64
Version: 1.4.2-1
Distribution: unstable
Urgency: low
Maintainer: Debian OCaml Maintainers <debian-ocaml-maint@lists.debian.org>
Changed-By: Ralf Treinen <treinen@debian.org>
 edos-distcheck - Checks whether dependencies of packages can be satisfied
 pkglab     - interactive environment to explore package repositories
Closes: 532771 532828
 pkglab (1.4.2-1) unstable; urgency=low
   * New Upstream Version
   * Merge in dql/help.ml and doc/pkglab.ml from upstream svn to fix
     missing quote before version strings (closes: #532771).
   * This package now supersedes the edos-[reb,rpm}check packages:
     - Add symlinks for /usr/bin/edos-{deb,rpm}check.
     - Replaces, Conflicts and Provides edos-{rpm,deb}check
     - Add manpages for edos-{deb,rpm}check
     - Add edos-builddebcheck
   * Patch distcheck/common.ml to accept the -checkonly option. Add a note
     on this to debian/NEW.Debian.
   * Add dependency on python-debian and python (closes: #532828)
 19b5aaba12d846f18939196fa7cd500e7be0e556 1353 pkglab_1.4.2-1.dsc
 7df170dc508b1401f28fefc13a549f320520d63b 48325 pkglab_1.4.2.orig.tar.gz
 7ce3e50d40d5e23b766635aebc658b387445d71d 10425 pkglab_1.4.2-1.diff.gz
 150ebccee4ff7f59c93332667f4817248b7c2818 557152 pkglab_1.4.2-1_amd64.deb
 26c4a750f85d56bb618dd2cf5fb8fa7c6d648cbd 457222 edos-distcheck_1.4.2-1_amd64.deb
 c11f4c9cc9ae912fd2c7106455dd5e39a03b422e208d41d82433b86da1a6b40a 1353 pkglab_1.4.2-1.dsc
 4ab8297e587db2e543fdb0c64586071eb200b9136b649d1c802e79ef04f7912d 48325 pkglab_1.4.2.orig.tar.gz
 a85afc07103d2df8bceb0c0c5be3900d329d8e83b5160f26eb9d5ead64291eb6 10425 pkglab_1.4.2-1.diff.gz
 6960f3775e8aac3ce562e7c67f0e475a60d343b1da01ddb9e57e5300e1356a83 557152 pkglab_1.4.2-1_amd64.deb
 05f00478504b0264ec8cc032e49eb534603dcd4290575d0cd220980a6d9be7de 457222 edos-distcheck_1.4.2-1_amd64.deb
 d31d9763e9d572cbcfc57a6376c954ab 1353 devel optional pkglab_1.4.2-1.dsc
 1bbf3f60f9cc829c39cda79826a4847f 48325 devel optional pkglab_1.4.2.orig.tar.gz
 c407ccfc4a6a4acbcc0189b624b24851 10425 devel optional pkglab_1.4.2-1.diff.gz
 16f72b6fb8df4e2121fef3dde1205234 557152 devel optional pkglab_1.4.2-1_amd64.deb
 2200c2c85dccbf414fff8ad9910e1ea9 457222 devel optional edos-distcheck_1.4.2-1_amd64.deb

Version: GnuPG v1.4.9 (GNU/Linux)


--- End Message ---

Reply to: