[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#527224: ocsigen: Ocsigen don't start with basical configuration

Package: ocsigen
Version: 1.1.0-2
Severity: grave
Justification: renders package unusable

the Ocsigen server don't start with the default configuration. The 
first error is : 

Fatal - While loading /usr/lib/ocsigen/extensions/ocsipersist-sqlite.cma: 
Dynlink.Error: interface mismatch on Sqlite3

Without load of this module, I have an other critical erros : 

Fatal - While loading /usr/lib/ocsigen/extensions/eliom.cma: Dynlink.Error: 
error while linking /usr/lib/ocsigen/extensions/eliom.cma.
Reference to undefined global `Ocsipersist'

I have this problem on two differents architectures (the other one is a x86).


Florent Fourcot.

-- System Information:
Debian Release: squeeze/sid
  APT prefers unstable
  APT policy: (500, 'unstable'), (500, 'testing'), (1, 'experimental')
Architecture: amd64 (x86_64)

Kernel: Linux 2.6.29-1-amd64 (SMP w/2 CPU cores)
Locale: LANG=fr_FR.UTF-8, LC_CTYPE=fr_FR.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/bash

Versions of packages ocsigen depends on:
ii  adduser                   3.110          add and remove users and groups
ii  libc6                     2.9-10         GNU C Library: Shared libraries
ii  libcryptokit-ocaml-dev    1.3-12         cryptographic algorithm library fo
ii  libncurses5               5.7+20090502-1 shared libraries for terminal hand
ii  libpcre3                  7.8-2          Perl 5 Compatible Regular Expressi
ii  libsqlite3-ocaml-dev      1.4.0-1        Embeddable SQL Database for OCaml 
ii  libssl0.9.8               0.9.8g-16      SSL shared libraries
ii  libzip-ocaml-dev          1.04-4         OCaml compression libraries (devel
ii  ocaml-findlib             1.2.4-2        Management tool for OCaml programm
ii  ocaml-nox [ocaml-nox-3.11 3.11.0-5       ML implementation with a class-bas
ii  procps                    1:3.2.7-11     /proc file system utilities
ii  psmisc                    22.6-1         Utilities that use the proc filesy

ocsigen recommends no packages.

Versions of packages ocsigen suggests:
pn  ocsigen-doc                   <none>     (no description available)

-- no debconf information

Reply to: